Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Aug 2014
    Location
    Slovenia
    Posts
    5

    Traxxas Bandit & 2S

    Dear Colleges,

    Would you be so kind and tell me if this is OK as follows

    - I have bought a new 2s lipo of 6000A and charge it...
    - after some time of driving i have checked on Digital battery checker and it's showing 3.668V for cell and 9% capacity of battery. Is this normal that battery will go almost to 0% when i will reach capacity app. 3.5V

    thanks in advance,

    Thomas
    Last edited by cuktom; 08-17-2014 at 10:52 AM.

  2. #2
    RC poster
    Join Date
    Aug 2014
    Location
    Slovenia
    Posts
    5
    And picture...


  3. #3
    Traxxas Employee TireSlinger's Avatar
    Join Date
    Sep 2010
    Posts
    553
    Under load (driving) the voltage will drop depending on how much current is being pulled by the power system. The 'safe' voltage for most LiPos is 3.0v per cell, so the ESC will usually cut off a tad before then.

    When not under load however the voltage will recovery slightly, so a pack might be drained and still showing 3.2 - 3.6v per cell depending on how big the current draw is and the quality of the cells.

  4. #4
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    10,125
    You'll need to contact the manufacturer for support of their battery.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •