Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    May 2014
    Posts
    2

    newbie to slayer. having trouble on first day. help me

    this is my first nitro, pick up a slayer nitro

    during the third tank of breaking in precedure, car stopped when i tried to start back on

    wheels were trying to go forward eventhough everything is in neutral,,

    so i pick up the car to start the engine, it starts but wheels are spinning, but when i tried to put it

    on the ground, engine shuts off....

    and i have no idea what the problem is..

    help me guys

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    10,572
    Clutch and/or spring are broken at the flywheel.
    The Super Derecho

  3. #3
    RC Qualifier
    Join Date
    Mar 2013
    Location
    Amarillo, tx
    Posts
    440
    Yup what double g said, the clutch spring is broken.
    Take off the e-clip on the clutchbell to take it off, and you should see your problem.
    2400kv rusty ~ 4100kv merv
    Revo .26 X2
    Jato .21

  4. #4
    RC Champion
    Join Date
    Aug 2013
    Location
    Brazoria, Texas
    Posts
    1,637
    +1 to that ^

    Nitro is fun. I enjoyed my slayer pro but it kept sucking up my money so I had to trade that for electric. Its noticeably cheaper.
    Spartan Jet Boat
    Alias
    Fiero GTP

  5. #5
    RC poster
    Join Date
    May 2014
    Posts
    2
    wow..thanks guys...
    spring was the answer....
    spring was broken and now its fixed...it rocks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •