Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Mar 2014
    Posts
    19

    Rx (2218) linking problem

    I have had to buy a new rx box (2218) and it will not link to my remote (6516). The guy at my hobbie shop could not get it and neither can i. Any suggestions ?

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    Receiver 2218 is not compatible with the 6516 remote.

    Whatever it is I just typed... could be wrong.

  3. #3
    RC poster
    Join Date
    Mar 2014
    Posts
    19
    That looks right. Thanks, looks like i wasted an hour today at the hobby shop because they couldn't figure it out.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    Should I send them the bill?
    Whatever it is I just typed... could be wrong.

  5. #5
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Greene Maine
    Posts
    391
    Quote Originally Posted by Jimmie Neutron View Post
    Should I send them the bill?
    I'm having a similar issue. Didn't want to create yet another "cant bind" thread. I've got the black transmitter 2238 and the 2218X rx and can't get them to bind. RX just blinks a slow red light when I follow the binding procedure. Thanks
    MERV + Custom LCG race slash

  6. #6
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Greene Maine
    Posts
    391
    Would it make a difference I don't have a servo plugged in?
    MERV + Custom LCG race slash

  7. #7
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    No, it wouldn't.

    What is the procedure you are following?
    Whatever it is I just typed... could be wrong.

  8. #8
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Greene Maine
    Posts
    391
    Hold set, turn tx on. Tx=blinking red. Hold the link button on rx and turn esc on. The esc turns solid green but the rx and tx keep blinking red. It's a VXL system on a 2s
    MERV + Custom LCG race slash

  9. #9
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    Both antenna are in good condition?
    Whatever it is I just typed... could be wrong.

  10. #10
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Greene Maine
    Posts
    391
    Yes, from wht I can see.
    MERV + Custom LCG race slash

  11. #11
    RC Qualifier
    Join Date
    Oct 2011
    Location
    Greene Maine
    Posts
    391
    Well, i got it. Just had to touch both antennas together. Now that they are bound the range is fine. Just needed to do that for them to bind. Thanks for the help
    MERV + Custom LCG race slash

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •