Results 1 to 11 of 11
  1. #1
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31

    TQi to Iphone communication issue

    I received my new Slash 4X4 Ultimate yesterday evening and turned everything on including the Iphone. When the Traxxas Link app started up it said it need a firmware upgrade so I let it do it's thing. When the 2 updates were installed everything worked as it should. I could see all functions of the dashboard working and was able to put it into training mode to run it in the house a bit. Now I take it out to run it outside for the first time and the Iphone and transmitter are not linking up. I changed batteries in the transmitter and that didn't help. The phone is fully charged and so is the 2s Lipo in the car. I uninstalled the app, installed it again and it still will not link with the transmitter. I'm lost as to what to do now. I posted this in the Slash 4X4 section before I saw this Traxxas link section.

  2. #2
    RC Racer
    Join Date
    Aug 2013
    Posts
    244
    With both devices off, connect iPod to base. Turn on transmitter and wait 5 seconds. Turn on iPod and wait for green connect light in upper left of traxxas link screen. Turn on car and wait for green link in upper right.

    If that doesn't work, try it in reverse turning iPod and traxxas link on, then turning on transmitter.

    This system is occasionally maddening trying to get it to work. If it fails again, contact Traxxas hot line. They may have other suggestions like 1st try resetting the transmitter to factory defaults (hold down both top red buttons and turn transmitter on), then try the above.

  3. #3
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31
    Quote Originally Posted by Dementor View Post
    With both devices off, connect iPod to base. Turn on transmitter and wait 5 seconds. Turn on iPod and wait for green connect light in upper left of traxxas link screen. Turn on car and wait for green link in upper right.

    If that doesn't work, try it in reverse turning iPod and traxxas link on, then turning on transmitter.

    This system is occasionally maddening trying to get it to work. If it fails again, contact Traxxas hot line. They may have other suggestions like 1st try resetting the transmitter to factory defaults (hold down both top red buttons and turn transmitter on), then try the above.
    That didn't work, calling Traxxas now. Thanks.

  4. #4
    Traxxas Employee
    Join Date
    May 2013
    Posts
    33
    Did you ever get the situation resolved?

  5. #5
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31
    No, had to send it to Traxxas.

  6. #6
    RC Racer
    Join Date
    Aug 2013
    Posts
    244
    Sometimes the upgrades initially work and then the TQi just fails and all you can do is spend money mailing in to traxxas to get it replaced. I think Traxxas should pay for it if it is a failure of their upgrade and TQi.

  7. #7
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31
    Quote Originally Posted by Dementor View Post
    Sometimes the upgrades initially work and then the TQi just fails and all you can do is spend money mailing in to traxxas to get it replaced. I think Traxxas should pay for it if it is a failure of their upgrade and TQi.
    I agree. They shipped mine back today, should have it Thursday. They said they replaced my transmitter as a one time courtesy....are you kidding me? It failed, and if the new fails when new I expect to have it replaced free of charge as well! I think it's not fair that we have to pay to send it to them, then they can't even tell you what was wrong, just that it was bad. I asked about the two firmware updates and all they could say is "if that were the issue then everyone would be having this issue".

  8. #8
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31
    My new TX and docking base arrived two days ago and all is fine now except that the iphone power button apparently doesn't work any more. Everything links up fine with each other every time now. When I put the iphone in the dock it didn't turn on because the phone had been sitting there for two weeks waiting for the new transmitter and it was turned on and I wasn't aware of it. Now the only way I can turn the iphone on is to plug it into the transmitter and turn the transmitter on, or plug the phone charger into the phone. To turn the phone off I have to go to accessibility mode in general settings, plus three more steps on the screen to shut it down. Anyone ever experience this with an iphone?

  9. #9
    RC Qualifier
    Join Date
    Nov 2012
    Posts
    740
    I've seen that all too often, you can have it replaced

  10. #10
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    516
    I read somewhere to turn on the airplane mode to avoid receiving the firmware update. Has anyone tried that with any success

  11. #11
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    31
    Quote Originally Posted by guy45ot View Post
    I read somewhere to turn on the airplane mode to avoid receiving the firmware update. Has anyone tried that with any success
    Traxxas tech said the firmware update had nothing to do with it and I have to believe him as the new TX got the same firmware upgrade and it works fine. I just had a faulty TX.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •