Results 1 to 4 of 4

Thread: tqi dramas

  1. #1
    RC Racer
    Join Date
    Nov 2012
    Posts
    179

    tqi dramas

    I have a big problem at the moment,6 trucks and 2 dead tx's.last night I was setting up my latest revo which has a brand new rx in it and everything was ok for a while but when I tied to set the end points ect it wouldn't respond then after a while the power light on the tx wasn't working at all and any truck I tried to test would just glitch,running a 6v hump in the tx also.
    so after that a grabed my spare tx with dock and started to set things up on that and everything was going ok,then it wanted to do a firmware update so I did that and retested everything was normal and kept on bind the rest of my trucks but after I got to to my 4th the pwer light went out and nothing responded.
    so now I have a big problem,i reset the tx on both of them,the first one powered up but when it does the led slowly blinks green and wont communicate with my ipod and sort of works on the trucks but glitches a little and the second one is as dead as a dodo
    does anyone have any ideas or am I destined to buy another new tx

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    I'd call Traxxas... but it seems when this happens it is almost cheaper to buy new even if Traxxas will cover the cost of the Tx due to shipping.

    Do you use the telemetry?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Racer
    Join Date
    Nov 2012
    Posts
    179
    cheaper to buy a new one,being in Australia is expensive sometimes,$100 later and ill have a new tx.ironically I got another one off ebay for $30 shipped but at the rate the post is I doubt it will show up before Christmas.

    now I have a different radio problem,brand new rx,1600mah hump pack,near new 2070 throttle and a brand new d652 solar servo for steering in my new ofna .28 jl power revo and the receiver keeps going into fail safe.
    I've done a bit of testing and I think the solar servo is drawing too much cause the fail safe mode.question is would a glitch buster solve the problem or am I better off getting a less grunty servo

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    All a glitch buster is is a capacitor... if you can make one they are really cheap to try out.
    Whatever it is I just typed... could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •