Results 1 to 2 of 2
  1. #1
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    594

    can a new 6518 receiver simply go bad??

    I'm having range issues on my 4907 maxx again. after messing up antenna on previous receiver traxxas sent me a brand new one. I installed it and had long range I mean like 400 feet range. well today I'm only getting like 90 feet range. this is just 3 hours of use into it. new batteries on transmitter and rx battery pack fully charged. rx antenna ia not cut or hard metal bent. did I receive a bad receiver?

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    594
    fixed it back online.!! last time I used my tmaxx was at the park big open field. this last time at my.condo complex. I startes ti think.... there is lots of wifi 2.4ghz routers at the condos... hmmmmm I loged into my router, disabled extended range mode, changed from channel 3 to channel 11. back to the tmaxx. recharged the rx battery pack even left it in trickle charge for a little. I cut the blue antenna tube so it only sticks out like an inch and a quarter above rx box. carefully routed excess antenna inside rx box so it don't get pinched when shut it. tested range with body on and. walked away a good 200 feet and I saw the tires steering back and forth not a single glitch. it looks cool too!!! shorty antenna tube. note... I did not cut antenna wire, only the blue antenna tube. I learned about this mod here in the forums. now I just need a.new glow plug.... this is what I get for not having spares on hand. ahhhh live and learn.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •