Results 1 to 25 of 25

Thread: Need revo help

  1. #1
    RC Enthusiast
    Join Date
    May 2013
    Posts
    21

    Need revo help

    I have my revo 3.3 and it keeps boging out on second gear it runs fine when it is in the air but when it had a load it bogs out and when the front tires are on the ground it fine but when the back tires are on the ground it bogs out NEED HELP PLEASE

  2. #2
    RC Racer
    Join Date
    Mar 2013
    Location
    Philly
    Posts
    114
    Bogging out sounds too rich lean it 1/8 of a turn on high speed needle. There are plenty of tuning tips on the traxxas website to help troubleshoot tuning issues.

  3. #3
    RC Racer
    Join Date
    Apr 2012
    Posts
    100
    your slipper could be loose

  4. #4
    RC Enthusiast
    Join Date
    May 2013
    Posts
    21
    If my slipper was loose then wouldn't my spur gear just be spinning

  5. #5
    RC Competitor
    Join Date
    Aug 2012
    Posts
    78
    If my slipper was loose then wouldn't my spur gear just be spinning
    Yes. The problem is a tuning problem. If the slipper were loose it would not bog it would just rev up really high and not go anywhere.

  6. #6
    RC Competitor
    Join Date
    Apr 2013
    Location
    mississippi
    Posts
    95
    So a couple quick questions? Do you have a temp gun? How old is your motor? Where are your needles at. Count as you turn them in and let us know. That will help me be able to help you more
    Zip ties work wonders for broken shock towers!

  7. #7
    RC Racer
    Join Date
    Mar 2013
    Location
    Philly
    Posts
    114
    Lol, just lean it out 1/8th turns until it stops. It's just loading up with fuel.

  8. #8
    RC Enthusiast
    Join Date
    May 2013
    Posts
    21
    Quote Originally Posted by just_plain_lost View Post
    So a couple quick questions? Do you have a temp gun? How old is your motor? Where are your needles at. Count as you turn them in and let us know. That will help me be able to help you more
    I start at like 2 1/2 turns from close and its pretty new and yes I have a temp guns

  9. #9
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Gurley, Alabama
    Posts
    794
    2 1/2 turns out on the hsn is way to lean and 2 1/2 on the lsn is way to rich.

  10. #10
    RC Enthusiast
    Join Date
    May 2013
    Posts
    21
    What should they be

  11. #11
    RC Competitor
    Join Date
    Apr 2013
    Location
    mississippi
    Posts
    95
    4 turns out on high needle and 1 3/4 out on low needle. That will be rich. And with your new motor I would start at 4 turns put and tune it 1/16 turns in. No motor has a set point. Things like temp, humidity, elevation and other things play a role. Look up traxxas setup guides. It explains it in detail.
    Zip ties work wonders for broken shock towers!

  12. #12
    RC Enthusiast
    Join Date
    May 2013
    Posts
    21
    Alright guys I got my revo running my pull start was bad so I replaced it and now it runs like a champ thanks guys!!!

  13. #13
    RC poster
    Join Date
    May 2013
    Location
    New York
    Posts
    6

    help needed out of control revo3.3

    Hey guys I have a problem with my revo 3.3 I was running the car last week and get out of control and crashed, yesterday I was running the car and went out of control again,i don't what might be, servo reciver? Can somebody help me?

  14. #14
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    89
    Already check car and radiocontrol batteries? are they loaded?

  15. #15
    RC Competitor
    Join Date
    Apr 2013
    Location
    mississippi
    Posts
    95
    What radio do you have? 2.4 ghz or 27mhz? If its new, ill assume its the 2.4. Like they said check your batteries. If your driving and the battery goes dead in the truck. The throttle will stick where its at and you cant steer the truck. If the batteries go dead in the remote. Then the truck will just stop. I first bought my 2.4, the reciever was bad, and I had to replace it.

  16. #16
    RC poster
    Join Date
    May 2013
    Location
    New York
    Posts
    6
    I have a 2.4 ghz and the batteries are new ,i don't know what happen with this car.... helppppppp

  17. #17
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    89
    Did you run it in the same place? try to go to other places, could be interference (who knows!)
    Have you checked the connections on the receiver?
    You dropped the remote control device and a wire disconnected inside?
    If all OK try to replace the receiver with a new one
    Last edited by Cyborg; 07-17-2013 at 03:45 PM.

  18. #18
    RC poster
    Join Date
    May 2013
    Location
    New York
    Posts
    6
    I always go to the same place but only happen with my revo ,when I go with my slash that never happen

  19. #19
    RC Competitor
    Join Date
    Apr 2013
    Location
    mississippi
    Posts
    95
    Just thought of this. The shift point to 2nd could be to low. Shifting to soon and a rich engine can cause a severe bog. Just food for thought

  20. #20
    RC poster
    Join Date
    May 2013
    Location
    New York
    Posts
    6
    some body told me that could be the battery of the revo?

  21. #21
    RC Competitor
    Join Date
    Apr 2013
    Location
    mississippi
    Posts
    95
    Very well can be.
    Zip ties work wonders for broken shock towers!

  22. #22
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    89
    So what was the problem?

  23. #23
    RC poster
    Join Date
    Jan 2009
    Location
    Hunderton County New Jersey
    Posts
    4
    Check this out I just switched out my throttle/brake servo for the 2075 servo (new) then when I went and drove it after about 5minutes or so the throttle started acting funny like it was sticking, then all of a sudden the revo just accelerated I couldn't brake but I could steer it. So this happened a few times more. So I checked the forums and everybody seam to say the same thing remove the opti drive and put FOC in it. well I bought the Hitec HPP-21 programmer and tester and tested all my servos and found one of the steering servo to be bad and glitching witch was robbing voltage from the rest of the servos and causing the the new throttle servo to go full throttle. Now I'm running all Hitec servos 7955TG Steering andd the 5645MG no more throttle problems.

  24. #24
    RC poster
    Join Date
    May 2013
    Location
    New York
    Posts
    6
    i already change the servo,opti drive,battery,reciever,remote control,and the car still doing the same thing this car is driving me crazy....please i need helpppppppp!!!!!!!!!!!!!!!!!!!

  25. #25
    RC Competitor
    Join Date
    Apr 2013
    Location
    Portugal
    Posts
    89
    I'm still noob in nitro ... does the clutch shoes may cause this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •