Results 1 to 19 of 19
  1. #1
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    5,125

    The Fix to the EZ Peak Plus Fan Noise!

    Hey guys, as some of you know, after a little while, the cooling fan on the EZ Peak Plus can "buzzing" or "grinding" sound at low speeds. Mine has been making funny sounds for at least 3 months now, but today, even at full fan speed, it wouldn't stop making grinding sounds. I didn't want to send it to Traxxas, I need it for a camping trip this weekend. (can't wait to take my Summit!) So, I took out the 4 screws holding it together, and I put a small drop of motor oil on the fan. Now, at any speed, the fan it really quite. Even at the very beginning, it's super quite! This could be just me, but it sounds like it's spinning even faster than it was when it was new! I just thought I'd post this for any one else that has the noise. I have no idea if this voids some warranty, but I figured it was worth a try.
    2SummitE/TmaxxVillainSlash2&4SlayerPndeTetonXMaxx

  2. #2
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    I had the same issue with my charger...I sent it in to Traxxas last month...They said they are replacing it with a new charger....But after 4 weeks...still no charger...

  3. #3
    Traxxas Employee
    Join Date
    May 2013
    Posts
    78
    If you have not heard from nor received your charger yet. Please call in so we can see what is going on.

  4. #4
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    Quote Originally Posted by blurrdvision View Post
    If you have not heard from nor received your charger yet. Please call in so we can see what is going on.
    Just called Traxxas....Guess the new chargers were on back order....The tech said it's on the way to me now...Hopefully with no more "bad" noises...

  5. #5
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    5,125
    Hopefully with no more "bad" noises...
    Remember, just a little drop of oil will make the noise go away...
    2SummitE/TmaxxVillainSlash2&4SlayerPndeTetonXMaxx

  6. #6
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,302
    Should not void warranty.. i have a charger by different name same issue.. sent it out for warranty and specifically told them i wanted the fan replaced and not a temp fix like oiling.. Well wen it got shipped back they forgot to remove the note that stated they removed the fan and oiled..

  7. #7
    RC Qualifier
    Join Date
    Aug 2012
    Posts
    298
    Well my fan would grind so much it would stop completly...I'm no engineer but I wouldn't want something I designed making noise like that and not funtioning properly new out of the box...Very common....I would recall them and address the issue not expect people to open a new item and oil it..

  8. #8
    RC poster
    Join Date
    Jan 2015
    Posts
    1
    Greetings fellow Traxxers!
    Just bought the Traxxas EZ Peak Plus 6 AMP 80 Watt Unit just yesterday and on both my 1st and 2nd charges also noticed this odd noise anomaly (obvious enough to cause concern for a first time user). I lightly tapped the fan area thinking was fan and hoping not A short circuit and sound subsided. Curious however did anyone out there purchase the new EZ Peak with I.D. recognition and still have same issue? I was. Going to purchase new unit however opted out as a) was not yet avail and b) would present compatibility issues with existing hardware. Anyhow, this seems to be a design flaw or substandard fan component built into the unit. I just hope it doesn't present or pose any safety issues. Traxxas appears to stand behind their products and services, perhaps this issue is deserving of a recall notice being posted on their web site or at a minimum inform users. Applying "a bit of oil" to such a sophisticated electronic device seems an odd way to deal with this odd issue. Mike Jenkins have anything to say? V

  9. #9
    RC poster
    Join Date
    Jan 2015
    Posts
    3
    I have had two of the 2970 ID chargers so far. Out of the box, the first one made terrible grinding noises at startup but then settled into the normal, somewhat loud "whir" after 20 seconds or so. If that wasn't bad enough, the sound got worse with pretty much every charge. Eventually (after less than 6-8 charges), the fan began sounding as if it was grinding down to a halt and also started to fail mid-charge.

    Since I had purchased via eBay (none of my LHS had stock), I ended up sending my 2970 in for warranty repair. I was extremely happy when I received a new, replacement unit that initially seemed to work great. No grinding or stopping - just a hairdryer-ish whirring sound while it ran.

    Unfortunately, the replacement unit's fan started grinding when I kicked off a final storage charge yesterday. So, I guess I’ll be opening mine up and adding some oil to the fan bearing. Based on the other reports here, it sounds like this will "fix" the problem for a while… but I shouldn’t have to do that with a device that has only been used a handful of times in a perfectly clean environment (no debris is being sucked into the fan).

    I just recently got back into RC after a very long break. (My last truck was a Midnight Pumpkin back in the early 90's.) The "Battery ID" system was a huge draw for me as I wasn’t fond of my son having to mess with LiPo charge settings. Unfortunately, the only "ID"-aware charger on the market so far has been somewhat of a letdown.

    The ID system is brain-dead easy to use, though... works exactly as advertised. I just wish Traxxas offered an ID charger that was built better and could charge at a much higher rate (for large packs at 1C).

  10. #10
    RC Enthusiast
    Join Date
    Nov 2014
    Posts
    45
    Ah! I have the same issue and Traxxas support told me it was normal? A bit concerning. In all my years of working with electronics, I absolutely know this is not a normal noise. The fan sounds like it is binding or is off balance. If a drop of oil solves the problem then there is obviously binding or too much friction which can lead to overheating or failure of the fan and eventually the charger which could be a bit of a problem.

    I was initially told I would receive a replacement and then told it was normal and not to worry about it.

    Not terribly excited about needing to tinker with a lipo charger but if a drop of oil will do the trick, so be it.

    Thanks for the tip!!!

  11. #11
    RC Champion
    Join Date
    Nov 2012
    Posts
    1,302
    I have the same issue with another brand. They even went as far as returning it for warranty repair to replace fan. Came back with a note in the box "fan did not need replacement just oiling". I thought it was quite funny to spend all that money in shipping on their part and just put a drop of oil in it and hope it lasts. Since it was brand new I went to the hobby shop showed them the note and told them I wanted a new one

  12. #12
    RC Enthusiast
    Join Date
    Mar 2015
    Location
    Oregon
    Posts
    42
    I just got one of these chargers and am having the same issue. What I've noticed is that if the charger is placed at an angle or held upside down it sounds perfectly normal. I don't want to flip the fan over, but I wonder if its installed upside down. When I place my hand near the vent, I don't feel any air being pushed out. I might just send it back and get a new one, but I don't know if that's going to fix the issue, because it sounds like all of you have gone through multiple units already and are still experiencing the problem.

  13. #13
    RC Qualifier RobertZ311's Avatar
    Join Date
    May 2015
    Location
    California
    Posts
    395
    Would 45wt shock oil work?
    Bash the Slash!

  14. #14
    RC Enthusiast
    Join Date
    Mar 2014
    Posts
    35
    yes it will work

  15. #15
    RC poster
    Join Date
    Sep 2015
    Posts
    4
    Same problem... Should be recall on these units!

  16. #16
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    5,125
    Quote Originally Posted by adi984 View Post
    Same problem... Should be recall on these units!
    Welcome to the forums!

    I doubt Traxxas will ever recall these, they sell probably over 10,000 of these a year, and only a few have the fan noise. At my hobby shop we sell at least 3-4 different brand chargers with fans like this one, and they too from time to time have fan noises. It's unfortunately part of these little fans, not all of them are ever 100% perfect.
    2SummitE/TmaxxVillainSlash2&4SlayerPndeTetonXMaxx

  17. #17
    RC Enthusiast
    Join Date
    Dec 2015
    Posts
    47
    haha great thread, same drama and ill add some oil to see if it fixes it??
    As far as the comments that these shouldnt do this. Absolutely correct however we live in this world of everything coming out of china. How ever even KTM (Greatest precision dirt bikes made in austria) Even leave the factory with dry ungreased head stem bearings?? Go figure??
    Last edited by mattryan; 12-27-2015 at 02:29 AM.

  18. #18
    RC Enthusiast
    Join Date
    Dec 2015
    Posts
    47
    hmm just pulled mine apart and really not sure how to get the oil onto the shaft. For info it was a little fiddly to pull apart and had 5 screws, with the fith screw hiding under the QC sticker haha.
    Then flicked the fan out and wanted to expose the shaft but its just pressed together, so just squirted a bit of onox in there (tiniest spray). Long story short I could of just sprayed it in without pulling anything apart.
    Note. Inox is non conductive doesnt dry thick etc so perfect for this application i think, unlike wd-40 etc.

    put it all back together and thought i buggered it as so quite had to visually inspect fan was running.
    Last edited by mattryan; 12-27-2015 at 10:46 PM.

  19. #19
    RC poster
    Join Date
    Sep 2015
    Posts
    4
    Seller said it's a common problem and suggested dual charger because they get less complaints on them... replaced it with dual charger... no noise from its fan.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •