Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Apr 2013
    Posts
    4

    stampede 2wd not working

    I just found this in my moms garage where I left it when I went away to college. I bought a new battery just because I knew the old one would be shot. I charged it and plugged it in and nothing happens. When I press the button nothing happens. If I hold the button it will stay green then flash red after about 6 seconds. Any ideas?

  2. #2
    RC Qualifier
    Join Date
    Nov 2012
    Posts
    740
    Still too many options narrow it a little please like what battery and what ESC and what transmitter/reciver (last one is more personal curiosity)

  3. #3
    RC poster
    Join Date
    Apr 2013
    Posts
    4
    I have the traxxas power cell 7.2v 3000mah, XL5 esc, 2019 receiver
    Last edited by TylerClutz; 04-19-2013 at 07:27 PM.

  4. #4
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    13,612
    Sounds like the esc is powering up fine. Its the yellow or blue xl5 esc?

    Do you have a local hobby shop? Take it there, and ask if they could try another radio to see if your esc, servo, and motor are good. If they are, either the radio is bad, or the crystals are bad. Either way, you will probably want to get rid of the am radio, and look on ebay for a 2.4ghz link radio and receiver for around 40$.
    Ya can't polish fertilizer...

  5. #5
    RC poster
    Join Date
    Apr 2013
    Posts
    4
    its the yellow xl5 esc

  6. #6
    RC Enthusiast
    Join Date
    Mar 2012
    Posts
    24
    My guess would be a burnt out motor. those tittan motors are very common to burn out unless they are broken in proberly but even then, dirt still gets in there. Take it to a hobby shop and see what they say. a motor is cheap! $25. also when the esc comes on will the servo work?

  7. #7
    RC poster
    Join Date
    Apr 2013
    Posts
    4
    the esc is not coming on. it will go into programming mode but thats it. my motor went out many years ago since then ive been running a Mabuchi motor RX-540VZ technigold

  8. #8
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    13,612
    I would go ahead and pick up a 2.4g radio. Your gonna want that no matter what. It is heads an shoulders above an am system.-Like I said, the chop shops on ebay have tons of these systems avail for cheap.

    Oh, you can check your motor. Pull the motor out, spray it out with motor cleaner, oil the bushings first. Then directly touch the motor leads to the battery connector. I usually duct tape the motor between the handles of a pair of pliers. It makes it easier...
    Last edited by rag6; 04-20-2013 at 11:35 AM.
    Ya can't polish fertilizer...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •