Results 1 to 17 of 17
  1. #1
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138

    sct 3800kv ??????

    I have had a sct 3800kv for a year now ben running 2s 3s on 20/90 a month ago I put 23/86 still running 2s/3s no heat prob. no glitches no prob. at all axcpt on 3s you cant give it all at any speed wheelies at 45 with badlands on the street like it way better with 2s 23/86 runs cool wheelies at will. for racing I run the 20/90 and my power curve top 3 allways (im not a great driver) lots of people welting things and bashing the sct I love mine and everyone hates it
    Last edited by superslasher; 04-09-2013 at 02:33 PM.

  2. #2
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Chino Hills,CA
    Posts
    305
    I love my cc still one of my favorite motors if I'm going sensoreless. It has everything you could ask for. Plenty of grunt and can be geared for speed. Runs cool through a wide range of gearing. It's just a good combo all around.
    2wd slash, PL LCG, CC 3800, Powerstrokes, S6040

  3. #3
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138
    is it sct 3800kv (sidewinder) after a year I water proofed it

  4. #4
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Chino Hills,CA
    Posts
    305
    Ya sv2 and mine is water proofed as well.
    2wd slash, PL LCG, CC 3800, Powerstrokes, S6040

  5. #5
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138
    cool I don't know what others are doing wrong I love mine

  6. #6
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    13,587
    I have not heard 1 bad thing about this motor as a bashing motor. As a racing motor it may have a ton too much umph for anything but the highest traction or big tracks.
    Ya can't polish fertilizer...

  7. #7
    RC Racer
    Join Date
    Dec 2012
    Location
    Cortland
    Posts
    127
    I just got one of these set-ups with a slash I bought and really don't like it. I manually changed the settings to traction control/ punch disabled, braking 50%, reverse 100%, no drag brake on. It seems to have less power/ speed than my velineon (geared the same). Also it goes straight from forward to reverse with no braking, which just makes the truck spin and I think it's hard on drivetrain parts. Anything I can check to make sure everything is working properly? Also when you push the truck by hand (electronics off) it seems to have spots where the motor stops(ie doesn't roll smooth/stutters). Is this normal for a 4-pole? Thanks

  8. #8
    RC Turnbuckle Jr. billy-bones's Avatar
    Join Date
    Nov 2012
    Location
    Michigan
    Posts
    5,502
    Quote Originally Posted by exrider720 View Post
    I just got one of these set-ups with a slash I bought and really don't like it. I manually changed the settings to traction control/ punch disabled, braking 50%, reverse 100%, no drag brake on. It seems to have less power/ speed than my velineon (geared the same). Also it goes straight from forward to reverse with no braking, which just makes the truck spin and I think it's hard on drivetrain parts. Anything I can check to make sure everything is working properly? Also when you push the truck by hand (electronics off) it seems to have spots where the motor stops(ie doesn't roll smooth/stutters). Is this normal for a 4-pole? Thanks
    It sounds like your programing is off. I run the side winder and the vxl-3 systems,with out issue. The castle has more low speed pull,and runs cooler.
    Are you using the field card?
    Or just the buttons on the esc? You said manually,I would assume just the esc,with out the use of the castle link.
    Last edited by billy-bones; 04-10-2013 at 08:44 AM.
    Built Ford Tuff With Chevy Stuff.

  9. #9
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138
    the defalt settings have punch control off you realy need a card or link so you can set and see all settings I have 10 0/0 drag brake 50 0/0 reverse and 50 0/0 brake and a modded power curve what your feeling is the 4 magnets and deff. need lipo's

  10. #10
    RC Champion
    Join Date
    Mar 2010
    Location
    Hackettstown,NJ
    Posts
    1,456
    Definately get the program card or better yet the Castle link. Mine is set up so well that there isn't much that can touch it as far as speed, control and off the line power. While I don't race my Slash at a track, I run it along with a 4 pole 5700 and the 3800 definately has more off the line power.
    Maxx3.3/ rusty5700/ slash3800/ slash5700 /4tec3.3

  11. #11
    RC Racer
    Join Date
    Dec 2012
    Location
    Cortland
    Posts
    127
    Quote Originally Posted by superslasher View Post
    the defalt settings have punch control off you realy need a card or link so you can set and see all settings I have 10 0/0 drag brake 50 0/0 reverse and 50 0/0 brake and a modded power curve what your feeling is the 4 magnets and deff. need lipo's
    Billy- Yeah, I am programming manually using the buttons to set everything.

    Superslasher- good to know that it's normal for the motor. I'm running 6600mah 65c 2 cell lipos. I don't want to waste money on a program card yet if I'm unimpressed by the combo.

  12. #12
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Chino Hills,CA
    Posts
    305
    Quote Originally Posted by exrider720 View Post
    I just got one of these set-ups with a slash I bought and really don't like it. I manually changed the settings to traction control/ punch disabled, braking 50%, reverse 100%, no drag brake on. It seems to have less power/ speed than my velineon (geared the same). Also it goes straight from forward to reverse with no braking, which just makes the truck spin and I think it's hard on drivetrain parts. Anything I can check to make sure everything is working properly? Also when you push the truck by hand (electronics off) it seems to have spots where the motor stops(ie doesn't roll smooth/stutters). Is this normal for a 4-pole? Thanks
    That stutter what I call notchy feeling is from the 4 pole. It's normal for it to do that.
    2wd slash, PL LCG, CC 3800, Powerstrokes, S6040

  13. #13
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    6,101
    Quote Originally Posted by TheDonJuan View Post
    That stutter what I call notchy feeling is from the 4 pole. It's normal for it to do that.
    This will occur on both 2 pole and 4 pole sensorless. If you go sensored it will go away.

    Like the other guys said, make sure you get the castle link and hook up to the PC. You have some programming to do, and maybe an update if you've had it for a while.
    My Black & Blue Rally is faster than your color...

  14. #14
    RC Qualifier
    Join Date
    Jan 2013
    Location
    Chino Hills,CA
    Posts
    305
    Quote Originally Posted by O.G. View Post
    This will occur on both 2 pole and 4 pole sensorless. If you go sensored it will go away.

    Like the other guys said, make sure you get the castle link and hook up to the PC. You have some programming to do, and maybe an update if you've had it for a while.
    My. Cc is the only sensores less motor I have everything else I own is sensored. I never purchased the card because it ran great on stock settings and I always placed top 5. If it isn't broke don't fix it. Lol
    2wd slash, PL LCG, CC 3800, Powerstrokes, S6040

  15. #15
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138
    went to bmx track today and put my sct 3800kv threw water test closed my eyes on first jump into a 12" deep puddle (first time wet) I water beat it for an hour wow was fun lockups worked great



    Last edited by cooleocool; 04-11-2013 at 11:06 AM. Reason: merge

  16. #16
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    6,101
    That's a pretty clean truck. Did you take the second pic before the water bashing?
    My Black & Blue Rally is faster than your color...

  17. #17
    RC Racer
    Join Date
    Mar 2013
    Location
    wa
    Posts
    138
    no water hosed it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •