Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Mar 2013
    Posts
    3

    Traxxas Russler XL. dies after 10 minutes

    I had problems with the car dieing after 10 minutes of use....red light flashing and sometimes if I unplugged the battery and reconnected it would reactivate and go for another 10 minutes. I suspected a bad battery and upgraded to a lipo, and am having the same problem....no more than 10 minutes run time and it dies. The car is fairly new with only about 10 hours of run time on it and i would like to get this operating properly. Any suggestions?
    Thx from canada

  2. #2
    RC Racer
    Join Date
    May 2012
    Posts
    102
    well if the red light blinking its LVD ( low voltage detection) probably gonna be the ESC

  3. #3
    RC Qualifier
    Join Date
    Aug 2011
    Location
    Columbia, SC
    Posts
    317
    You will probably get your best answers in the Rustler forum.
    Traxxas gone bye bye!

  4. #4
    RC Qualifier
    Join Date
    May 2012
    Location
    la porte
    Posts
    697
    It could be the thermal protection but I would check in the rustler forum


    Sent from my iPhone using My Thumbs
    6S OR NOTHING............................ maybe 5s

  5. #5
    RC Turnbuckle Jr.
    Join Date
    May 2011
    Posts
    7,262
    Quote Originally Posted by mydudrevo View Post
    It could be the thermal protection but I would check in the rustler forum
    i agree, its the thermal protection shut down on you.
    humay has left the building, peace.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •