Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jan 2013
    Posts
    2

    trimming the DR1

    I am having a lot of trouble setting the trim on my DR1. Everytime I go to lift off it goes in a different direction. I have been trying to get it up for 2 weeks. no amount of trim seems to do anything to stop this. This is the first 4 channel I have flow. This morning I found that the lower gear was loose on the shaft, I got that tightened but it still does the same thing. I have tried doing a reset on the transmiter but that doesn't help either!! Unless I'm not doing it right. Is there a video for this reset, like there is for QR1??? Does anyone have any suggestions??
    Thanks in advance,
    Les

  2. #2
    RC Enthusiast
    Join Date
    Apr 2011
    Posts
    46
    i have the same kind of problem. not sure why.. but once the heli is in the air it seems to be pretty stable its just when its first taking off, i also had this problem when messing with my brothers heli's (there not traxxas).

  3. #3
    RC poster
    Join Date
    Jan 2013
    Posts
    2
    Thanks for the reply traxxas777. I tried the reset on the controller this afternoon and it seems to have helped some. I don't know why all the other times I set it didn't do anything.It'll try tomorrow to see how it flies in a bigger area and see how it does. I'll get this up and flying right yet.
    Les

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •