Results 1 to 9 of 9
  1. #1
    RC poster
    Join Date
    Nov 2012
    Posts
    14

    Slash 2WD Steering Alignment/tire Alignment Problem

    I recently was testing out how far my Traxxas slash will go before it goes out of range. Well I'm running a brushless Velineon system and a 11.1v 35c 3s Lipo. Long story short when I lost reception of the car it floored it 60mph into a mail box a mile down my street!!!! I picked it up, no rods were bent but IT WAS HAVING A VERY HARD TIME STEERING AND HARDLY STEERED RIGHT AND PULLED TO THE LEFT. I bought VXL Aluminum Rods front and back and when I was putting them on the front the tire alignment is waaaay off. Idk what I did wrong! One tire is straight, the other is turned completely the opposite direction! I have shirtsnd the new aluminum rods and extended them and there was no change. HELP!!!!!!!

  2. #2
    RC Racer
    Join Date
    Sep 2012
    Location
    Denver, CO
    Posts
    112
    Did your bellcranks pop out of the chassis?

  3. #3
    RC poster
    Join Date
    Nov 2012
    Posts
    14
    I'm not sure what those are?

  4. #4
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    6,101
    Take a look at the front skidplate underneath the truck where the white servo saver is located. Those long white rods might have popped out of their seats. They are supposed to be nice and tight but often pop out after a big hit. If its not those, your servo saver probably moved.
    My Black & Blue Rally is faster than your color...

  5. #5
    RC poster
    Join Date
    Nov 2012
    Posts
    14
    Quote Originally Posted by O.G. View Post
    Take a look at the front skidplate underneath the truck where the white servo saver is located. Those long white rods might have popped out of their seats. They are supposed to be nice and tight but often pop out after a big hit. If its not those, your servo saver probably moved.
    Ok! When I crashed I looked under and saw the two white rods. ONE OF THEM WAS OUT OF PLACE SO I LOOSENED THE BLACK SUPPORT X BAR AND POPPED THE WHITE ROD BACK IT. Is there some how that I put it back in wrong?

  6. #6
    RC poster
    Join Date
    Nov 2012
    Posts
    14

  7. #7

  8. #8
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Dallas
    Posts
    570
    Can't see much in that pic, but search "bellcranks popping out" for some tips. It's an easily fixed minor design flaw on Slashes.

  9. #9
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    6,101
    I fixed the problem with an RPM skidplate and TRX bellcrank which locks them in a little better.. okay a lot better. But nothing will help if you have a 60mph impact.

    Also check the c-block pins, o
    Last edited by O.G.; 12-19-2012 at 09:39 AM.
    My Black & Blue Rally is faster than your color...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •