Hi all. Just joined the site today. I purchased a 2011 (new to me) Summit (1/10) last week and all I can say is WOW!! I was a little leery because I had read the people thought they were too slow. I have not had an RC for quite a few years now but this thing is very cool. I wasn't looking for anything fast, just something that could handle all conditions (especially snow) and also climb. So far I am very pleased to say the least.

I do have an actual question though. Last night I read through the entire FAQ and a couple other threads dealing with NiMh and LiPo battery comparison's. The truck came with (2X) 8.4V 3800mAh Tenergy Sub-C batteries, and those seem to work OK. Although, when I charge them (I have an Onyx charger) they seem to only charge up to 2700-2800 according to the charger. Is this because they have been used a lot and are probably on their way out the door?? Also, I got a second set with the truck also. They are Venom power 8.4V 4200 mAh and here's where the major problem is. One battery will charge up to about 3300 but the other says it's fully charged when it hits about 1100. I am guessing the battery is shot??

Any ideas on the battery issue would be great.

Also, I was thinking about switching to LiPos (have read a ton on that as well) but I have the EVX-2 that DOES NOT have the LVD. Can I just buy the newer EVX-2 that has the LVD and just swap it out?? Is it basically just a plug-n-play install? And out of curiosity, is it just an alarm that sounds when you start getting a low battery??

Appreciate the help and I look forward to being part of the Summit community!!


Chris