Results 1 to 10 of 10

Thread: E-Maxx problems

  1. #1
    RC poster
    Join Date
    Nov 2012
    Posts
    5

    E-Maxx problems

    Hello, i got myself a new motor and esc, instaled it and where redy to go.
    I tryed to turn and the servo was way to slow than it should and have been.
    The only modfie i did was setting my tqi radio to manufacture mode. Like it was before i got my car.
    Do somebody know what the problem is?
    sorry for my english, im just and 7 grader in a swedish shool :P
    I did also clean my servos outside from gravel and puted it back toghter...

  2. #2
    RC Qualifier
    Join Date
    Jun 2011
    Location
    North-West Ohio
    Posts
    978
    Have you tried re-binding the transmitter to the receiver?
    What motor/esc combo are you running now?
    Did you have these problems with the old motor and esc's?
    God is good.

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    On the last ride how was it steering? Was something stuck and you kept on turning ?
    Did you clean.the servo with water?

    Check the steering expo on the radio

    If it's a mamba esc and you have a castle link check the because voltage mine is set at 6v
    Last edited by 50togo; 11-21-2012 at 09:54 AM.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    I find that most ESC's do not put out 6v to the servos like Traxxas ESC's do.
    That would cause a slower servo.
    Whatever it is I just typed... could be wrong.

  5. #5
    RC poster
    Join Date
    Nov 2012
    Posts
    5
    I have the hobbywing 1:8 brushless system!
    My car was running fine until i changed my motor and esc to hobbwing from mamba monster.
    i did take out one of my servos and took away some smal stones from the litle holes betwen the servo and the chassi.
    On my old mamba it was just running perfectly until i wanted to go into the wett forest...
    I might go to my local hobbystore tomorrow and se if they can help me

  6. #6
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    do you still have the mamba system to test it with or check the voltage going to the servo.

  7. #7
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,271
    Unfortunately the MMM ESC is not waterproof and any water will kill it...I've done one from water already.
    Rock n Rolla !

  8. #8
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,849
    you need to program your new setup. you need to calibrate the system with the tx and esc like the forward, reverse, neutral. i did to mine. I havent ran into any trouble. my embe had a MMM, spartan combo in it, now hobbywing 1/8 system all working good.
    DEU 8:18 ESV

  9. #9
    RC poster
    Join Date
    Nov 2012
    Posts
    5
    Well, i did buy a new one and the problem did disapear! I have a lot of fun with it now. Bwt thanks for the help

  10. #10
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,849
    no problem anytime you need or have questions post them up were all here to help the fellow rc'er out.
    I picked up the wp sc8 esc+2000kv xerun motor both hobbywing products. running real cool and excellent so far.
    DEU 8:18 ESV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •