Results 1 to 4 of 4

Thread: T Maxx Help

  1. #1
    RC poster
    Join Date
    Mar 2011
    Posts
    3

    T Maxx Help

    Hi, I bought an old T Maxx from a yard sale and after a new radio and some cleaning everything worked fins. Then one day I was noticing it started to jerk a bit and soon after it got stuck in reverse. I've had the trans out 3 times now but can't figure out why it's still stuck in reverse every time I get it back in the Maxx. It's the Maxx they call "Classic" with the 1.5 pro engine. I don't want to get rid of it but it's starting to drive me crazy...............in Reverse! Has anyone had this problem with their Maxxes or Revos or anything and what can I do to fix it other than send it to an expensive hobby shop for repairs? Thanks

  2. #2
    RC poster
    Join Date
    Jul 2016
    Posts
    19
    Well, if it's the same as new stuff in the transmission, you could just remove the reverse gears or disable the servo that switches it into reverse for a right-now fix.

    Other than that..if the transmission is how it's suppose-to be, is your reverse servo fine? Maybe try swapping it for another servo(steering would probably be the safest for temporary test purposes, just don't go high speed)

    If it's not the servo, maybe just rebuild the transmission or get a new one

  3. #3
    RC Racer
    Join Date
    Jul 2002
    Location
    Atlanta Georgia
    Posts
    110
    I doubt you will ever see this, but mine did the exact same thing. The grease on the little arm that comes out to engage forward had solidified and it was no long able to come out. Cleaned the gear and the little arm, and it worked fine afterwards.
    Slash- 7.4v Lipo sidewinder 4600kV)

  4. #4
    RC Turnbuckle Jr. Nitronaught's Avatar
    Join Date
    Oct 2005
    Location
    South Florida
    Posts
    19,211
    Quote Originally Posted by Hawkeye40313 View Post
    Hi, I bought an old T Maxx from a yard sale and after a new radio and some cleaning everything worked fins. Then one day I was noticing it started to jerk a bit and soon after it got stuck in reverse. I've had the trans out 3 times now but can't figure out why it's still stuck in reverse every time I get it back in the Maxx. It's the Maxx they call "Classic" with the 1.5 pro engine. I don't want to get rid of it but it's starting to drive me crazy...............in Reverse! Has anyone had this problem with their Maxxes or Revos or anything and what can I do to fix it other than send it to an expensive hobby shop for repairs? Thanks
    The forward reverse gear will not change if the RPM's do not drop low enough. Try dropping the idle a little bit and blip the throttle a little when trying to change from forward to reverse.

    But yeah, you can drop reverse which is what most do. Even the Pro 15 version you can use the FOC kit.
    All Lives Matter
    United We Stand, Divided We Fall

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •