Results 1 to 10 of 10

Thread: Radio or lag

  1. #1
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461

    Radio or lag

    I upgraded my brushed slash to brushless now i either have lag or radio glitch i dont understand batteries in radio good maybe i should resync radio to receiver
    I BLAME ALL THIS ON POPOXX!

  2. #2
    RC Champion
    Join Date
    Dec 2010
    Location
    Michigan
    Posts
    1,118
    Rebinding or resyncing it would be the first step to try. Do that then tell us the results.
    Stampede 4x4
    Anza Slash VXL
    Rustler VXL

  3. #3
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    Did it tonight to dark to test ill let yall know tomorrow in daylight
    I BLAME ALL THIS ON POPOXX!

  4. #4
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    Did not make a difference installed new radio batteries no difference turned off bluetooth on smart phone no difference but what i did notice i was below the truck so maybe 2.4ghz works on a site line or straight line can anyone confirm that?
    I BLAME ALL THIS ON POPOXX!

  5. #5
    RC Racer
    Join Date
    Feb 2012
    Posts
    109
    What brushless system are you running and what batteries? My Castle 4 pole doesn't handle Nimh (definite sputtering) or low C rated Lipos too well. 25C seems to be the lowest for consistent, smooth power delivery with my 3800 SCT.

  6. #6
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    Its traxxas velineon running gens ace 4000mah 2c
    I BLAME ALL THIS ON POPOXX!

  7. #7
    RC Racer
    Join Date
    Feb 2012
    Posts
    109
    IMHO, 20C should be sufficient for your Velineon. Any way you can test another 2.4 GHz transmitter? I had a problem months ago (interference/faulty transmitter) and had to figure it out by process of elimination. If all else fails you can send your transmitter and receiver to Traxxas and they will test it for you.

  8. #8
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    If i had a spare i would i hate being broken ill keep yall informed
    I BLAME ALL THIS ON POPOXX!

  9. #9
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    Ive got a bad reciever switched recievers all good thanks for help
    I BLAME ALL THIS ON POPOXX!

  10. #10
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    461
    Update wasnt receiver i guess it was transmitter i changed to another brand and now it goes all the way to the end of road and still responds great.
    I BLAME ALL THIS ON POPOXX!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •