Results 1 to 7 of 7
  1. #1
    RC Competitor
    Join Date
    Sep 2012
    Location
    Houston, TX
    Posts
    66

    Revo ez start problem

    Got a traxxas revo 3.3 used. Guy said when running it cold to put fuel in carb. Check. When i go to start it it starts. Check. But when I pull the ezstart out its stops. Help
    Thanks

  2. #2
    RC Champion
    Join Date
    Mar 2012
    Location
    Grafenwoehr Germany
    Posts
    1,302
    Change ur glow plug...and if that doesn't work check the output of ur blue wire should be about 1.25v I think ...... Ultimately I would buy a glow ignitor and a pull start

  3. #3
    RC Competitor
    Join Date
    Sep 2012
    Location
    Houston, TX
    Posts
    66
    Replaced the glow plug and BOOM stated right up. Thank a ton Emaxx 1991

  4. #4
    RC Champion
    Join Date
    Mar 2012
    Location
    Grafenwoehr Germany
    Posts
    1,302
    Anytime bud

  5. #5
    RC poster
    Join Date
    Oct 2016
    Posts
    1
    Hey guys, sorry to post in this thread but I can't find anything closer. I have a revo 3.3 that I can't get started. I can't figure out what I'm missing here. I get fuel to the carb, I have a good glow from the glow plug, I have the carb h needle at closed -4 and the low flush to the inner rim of the throttle, the idle screw is set to approx 1mm gap. This is not rocket science yet I can't get the darn thing started. I stripped it down, cleaned the piston and sleeve, the c rod is fine, put it back together, took the carb appart, cleaned it out, made sure nothing is blocking the fuel intake, everything is lubricated and turning smooth, no crack, no leaking, I have the easy start, the engine cranks fine, turns over great, getting fuel, I primed it, crank, glow plug Why is it not starting? Anybody see something I'm missing? What did I not think of? Any idea is much appreciated because I'm close to seeing what this thing looks like when a real truck runs over it. ;-)

  6. #6
    RC Champion
    Join Date
    Dec 2006
    Location
    camillus, ny
    Posts
    2,850
    Quote Originally Posted by 1976Stevep View Post
    Hey guys, sorry to post in this thread but I can't find anything closer. I have a revo 3.3 that I can't get started. I can't figure out what I'm missing here. I get fuel to the carb, I have a good glow from the glow plug, I have the carb h needle at closed -4 and the low flush to the inner rim of the throttle, the idle screw is set to approx 1mm gap. This is not rocket science yet I can't get the darn thing started. I stripped it down, cleaned the piston and sleeve, the c rod is fine, put it back together, took the carb appart, cleaned it out, made sure nothing is blocking the fuel intake, everything is lubricated and turning smooth, no crack, no leaking, I have the easy start, the engine cranks fine, turns over great, getting fuel, I primed it, crank, glow plug Why is it not starting? Anybody see something I'm missing? What did I not think of? Any idea is much appreciated because I'm close to seeing what this thing looks like when a real truck runs over it. ;-)
    Do you have another plug you can try? Or a regular glow plug ignitor? Also does the truck roll freely?
    Man i need more than 50 characters.

  7. #7
    RC Racer
    Join Date
    Oct 2016
    Location
    utica ny
    Posts
    115
    Try a new plug,but first i would remove the plug and spray the engine with wd 40, spray down the carb lots and down the plug hole,make sure its getting fuel and that your fuel is still good, did you use anything for after run before you stored the truck? If not let the engine soak longer to loosen the crud in the crank,berings,ports ect. Also if the engine is gummed up from not performing after run procedure then the engine will act as if the clutch is broke and not fire if this is the case the wd will get it going but if it has surface rust it wont last longer than two gallons iv had many many engines and iv neglected a few this is my experience, also check your clutch bell bearing and clutch for drag,put the truck in the air while cranking the ez start, any wheel movment means clutch bell bearings or shoes
    Everything dies..everything..no,no,no,no

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •