Results 1 to 3 of 3

Threaded View

  1. #1
    RC poster
    Join Date
    Aug 2012
    Posts
    2

    SLAYER TRX 3.3 engine problem

    My slayer is 1 month old . I did the break in procedure (traxxas method) and after the break in i tuned it. for the first few week she was running beautifully!!! took care of the motor and cleaned her up and did the after run procedure on the engine . Then When you see asterisks, it means you've tripped the language filter, please review your posts, if you see asterisks, you have 45 minutes to edit them out, then the system prevents editing broke loose!!! She starts up fine and idles really nice but the problem is when i HIT half throttle she looses power and hesitates.SHE DOSE NOT STALL but she just hesitates on 1/2 to full throttle and She wont even go 2nd gear anymore. I really dont know whats going on here . Some of you might say that i might be running TOO LEAN. But thats not the case bc ive richen her up and it still does the same thing. I even returned her to factory settings!!! I did some research on line and majority says that its running too lean But i already eliminated that problem by richen the HSN and by returning it to factory settings (4 turns OUT from closed). I already replaced the glow plug but she still having the same problem. I was thinking maybe the fuel line is clogged but everything seems to be in order. if some one pls can help me i would really appreciate it . I really dont want to buy a new engine for this ($150) bc the original engine is brand new!!! I will be posting a video on youtube and add the link on this thread !! IM A NOOB TO NITRO RC
    Last edited by Nitronaught; 08-16-2012 at 08:30 AM. Reason: tripped language filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •