Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Feb 2013
    Posts
    8

    Broken axle connector?

    Hi All

    Just 2 days into it and I am already breaking stuff on my new summit. Drove it in the morning in our lawn and just now i saw that the axle connector(or what it is actually called) on the rear right wheel is broken but the axle itself is just fine. Just wanted to know if this can be easily fixed and if any of you went through this.


  2. #2
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,271
    http://traxxas.com/forums/showthread...=1#post5327789

    and here

    http://traxxas.com/forums/showthread...=1#post5332016

    EDIT: have a read through the thread if you like...it may be of some use to you .
    Rock n Rolla !

  3. #3
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    holy what did you do? lol

    probably need to buy a replacement tra# 5654 but how did you do that?
    What's a coffee if it aint Irish

  4. #4
    RC poster
    Join Date
    Feb 2013
    Posts
    8
    I am guessing it has something to do with the slipper clutch adjustment I did in the morning. May be I made it too tight....

  5. #5
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    lol maybe, tighten it all the way and then loosen it about 3/4 of a full turn with the tiny wrench
    What's a coffee if it aint Irish

  6. #6
    RC poster
    Join Date
    Feb 2013
    Posts
    8
    Hi Guys

    So here is the update. I had a chat with the tech support guys at Traxxas and supposedly it is part 5678 which is broke. I am getting it from Traxxas but the only way I can replace it is to take apart the rear differential assembly. I searched on youtube on how to do it but no help. Does any one have a guide?

    Woody

  7. #7
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,271
    Last edited by MITCH316; 02-26-2013 at 09:02 PM.
    Rock n Rolla !

  8. #8
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    Use photobucket to show pictures on here woodraider

    I noticed your image link didn't work up there
    What's a coffee if it aint Irish

  9. #9
    RC poster
    Join Date
    Feb 2013
    Posts
    8
    Thanks for the advice. Looks like my problem was very frequent in Summits back in 2009-2010 and part 5678 was supposed to be defective. But the replacements were working fine. So hoping Traxxas would send a good quality part and not the old stock!!

    http://traxxas.com/forums/showthread...-out-put-shaft

  10. #10
    RC poster
    Join Date
    Feb 2013
    Posts
    4
    Welcome to the club! Happens all the time. Easy fix as long as you have a 1.5mm Alan wrench... Doesn't come with tool kit. The part is only $8 and for 2. Rt front & Lt rear, Lt front & rt rear. I would buy extra!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •