Results 1 to 20 of 20
  1. #1
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85

    Stampede won't run?

    So, I am new to the RC car hobby. I recently purchased a Traxxas Stampede 2wd xl-5 with the Titan 12T 550 motor. Today, I received a 4200mah 7 cell battery in the mail as the 3000mah 7 cell didn't give me much running time. I used both batteries earlier today fully charged...well, just now the new 4200mah finished charging again and I plugged it in and the esc lights up, the receiver works the servo just fine, but now it won't run. I have no idea what could be the issue...I've tried to recalibrate the esc and receiver, but it doesn't seem to be working like it did the first time. I am charging the 3000mah battery that came with it and will try that one. Should I not have used the 4200mah battery with the stock Stampede? Any help or insight will be greatly appreciated. Thank you.

  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    No that battery is great for the stampede, thats not the problem.
    Are both the motor wires connected to the esc? Are the wires damaged?
    If that isn't the problem the motor might be fried. They are known for that. Connect each of the motor wires to each end of a aa battery and see if it runs.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  3. #3
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Nothing appears to be damaged. A double A battery? Nothing happens when I touch the motor to the ends of the double A battery. I Just got this Stampede a week ago

  4. #4
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    Quote Originally Posted by EvilE123 View Post
    Nothing appears to be damaged. A double A battery? Nothing happens when I touch the motor to the ends of the double A battery. I Just got this Stampede a week ago
    Did you buy it new, or used? Just curious maybe if you bought it used you got someone else headache
    I have only come here seeking knowledge

  5. #5
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    Did you buy it new, or used? Just curious maybe if you bought it used you got someone else headache
    I bought it new

  6. #6
    RC Turnbuckle Jr.
    Join Date
    May 2011
    Location
    Fraser Valley, BC Canada
    Posts
    3,137
    Motor is done. Hook it straight to your RC battery to be sure. As a last ditch effort you might be able to revive your motor for a little bit by spraying a really healthy dose of electric motor/contact cleaner on it and give some love taps with the end of a screwdriver or put it in a bowl of water overnight then blow it out with air and spray motor cleaner on it. Worth a shot.
    I don't have shelf queens, I have bash kings!

  7. #7
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    sounds like problems with the Traxxas motors, yours must be shot. Is that not a warranty issue?
    I have only come here seeking knowledge

  8. #8
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    sounds like problems with the Traxxas motors, yours must be shot. Is that not a warranty issue?
    One customer service rep said that they are not covered by warranty and to send in the motor. I called again and a different guy took my info to ship out a new one.
    Last edited by EvilE123; 07-19-2012 at 03:38 PM.

  9. #9
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    Quote Originally Posted by EvilE123 View Post
    One customer service rep said that they are not covered by warranty and to send in the motor. I called again and a different guy took my info to ship out a new one.
    I have another brand of motor in my pede, I find it strange that these Traxxas motors keep burning up.
    I have only come here seeking knowledge

  10. #10
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    I ordered a different one as well just in case, but I'm not sure I want to keep going through motors. If I send a few items back...after I'm credited I may just get the Hobbypartz brushless setup. What motor are you running?

  11. #11
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    I am running Novak 10.5 & 8.5 ballistic motors Havoc Pro SC esc. I got this for an exchage for some bad motors and esc's I sent into Novak. Put them on my BC pede got steel transmission gearing and look out. I shoud do some research on the Traxxas systems to see what they are and what they cost. I think Novak is more expensive, but I used what I had and it kicks but.

    Originally I had it geared 22/76 and it was killer fast, and very hot when I temped it so I shut it down and put in the 86 spur. Not so fast, but still allot of punch
    I have only come here seeking knowledge

  12. #12
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    I am running Novak 10.5 & 8.5 ballistic motors Havoc Pro SC esc. I got this for an exchage for some bad motors and esc's I sent into Novak. Put them on my BC pede got steel transmission gearing and look out. I shoud do some research on the Traxxas systems to see what they are and what they cost. I think Novak is more expensive, but I used what I had and it kicks but.

    Originally I had it geared 22/76 and it was killer fast, and very hot when I temped it so I shut it down and put in the 86 spur. Not so fast, but still allot of punch
    I honestly have no idea what anything you said means. Gears...beyond me.

  13. #13
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    The easiest thing to do if Traxxas sent you a "new" motor will be to plug it into the same wires and put the same pinion gear on it and set the mesh and see if it runs. If you get it running you are already ahead and can think about upgrading in the future when money is available. You said the Traxxas rep said he would ship one out right? Then try that motor and get it to work using the stock parts that you have.

    When you recalibrate the radio to the esc, and the motor would not run, the motor was dead at that point. You did nothing wrong, ask TRAXXAS to send you a new motor. It should have nothing to do with the batterys that you are using, they are just two different capacity batterys, both good. When you plug the new motor in to the wire.

    Tighten it down, set the gear mesh by putting a piece of paper cut to about 1/4 " ,between the pinion and the spur. Turn the gears by hand tand push the pinion and the spur are clamping the paper. Tighten down the motor screws rroll the gears by hand to run the paper out. The mesh is set. power up your Transmitter then your truck receiver and see if you truck goes with the new motor
    Last edited by MidnightPumpkin; 07-19-2012 at 10:22 PM.
    I have only come here seeking knowledge

  14. #14
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    I bought everything as a set brand new. The charger was terrible, but in a sense a god send since you can't run the thing for more than 20 minutes without having to let it cool. But, I bought another charger that charges a battery in 90 minutes instead of 8 hours. Another battery that was supposed to give me more run time, but didn't. Maybe cause my motor was on the way out. I got the rpm front bumper, Stub carriers w/ bearings from strc, front knuckles w/ bearings from strc, and caster blocks from strc. I just got the traxxas shock caps in the mail today. I had I not bought all that I could have got the brushless system from hobbypartz

  15. #15
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    The easiest thing to do if Traxxas sent you a "new" motor will be to plug it into the same wires and put the same pinion gear on it and set the mesh and see if it runs. If you get it running you are already ahead and can think about upgrading in the future when money is available. You said the Traxxas rep said he would ship one out right? Then try that motor and get it to work using the stock parts that you have.

    When you recalibrate the radio to the esc, and the motor would not run, the motor was dead at that point. You did nothing wrong, ask TRAXXAS to send you a new motor. It should have nothing to do with the batterys that you are using, they are just two different capacity batterys, both good. When you plug the new motor in to the wire.

    Tighten it down, set the gear mesh by putting a piece of paper cut to about 1/4 " ,between the pinion and the spur. Turn the gears by hand tand push the pinion and the spur are clamping the paper. Tighten down the motor screws rroll the gears by hand to run the paper out. The mesh is set. power up your Transmitter then your truck receiver and see if you truck goes with the new motor
    It'll go...But for how long ya know? I bought everything as a set brand new. The charger was terrible, but in a sense a god send since you can't run the thing for more than 20 minutes without having to let it cool. But, I bought another charger that charges a battery in 90 minutes instead of 8 hours. Another battery that was supposed to give me more run time, but didn't. Maybe cause my motor was on the way out. I got the rpm front bumper, Stub carriers w/ bearings from strc, front knuckles w/ bearings from strc, and caster blocks from strc. I just got the traxxas shock caps in the mail today. I had I not bought all that I could have got the brushless system from hobbypartz. I am happy with my purchase I just wish I would have thought some purchases through more clearly. I can't keep replacing brushed motors because of my budget.

  16. #16
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    Are they charging you for new Titan 12T 550? If they burn up that fast, I would ask Traxxas to replace them for free. I have sent a novak motor in, that was out of warranty, and they replaced it for free. Just saying you should get some service from Traxxas. MP

    btw all the upgrades that you have purchased will help in the long run. I hope someone else jumps in here that knows more about the Titan 12T 550, I have never ran one of those.
    Last edited by MidnightPumpkin; 07-20-2012 at 01:53 PM.
    I have only come here seeking knowledge

  17. #17
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    Are they charging you for new Titan 12T 550? If they burn up that fast, I would ask Traxxas to replace them for free. I have sent a novak motor in, that was out of warranty, and they replaced it for free. Just saying you should get some service from Traxxas. MP

    btw all the upgrades that you have purchased will help in the long run. I hope someone else jumps in here that knows more about the Titan 12T 550, I have never ran one of those.
    No, they are not charging me for the Titan replacement motor. Yeah, through the research I've done I figured those would be the first necessary upgrades to make.

  18. #18
    RC Qualifier
    Join Date
    Aug 2008
    Location
    Michigan
    Posts
    395
    Evil, which esc are you using? Just trying to find a motor for you, MP
    I have only come here seeking knowledge

  19. #19
    RC Competitor
    Join Date
    Jul 2012
    Posts
    85
    Quote Originally Posted by MidnightPumpkin View Post
    Evil, which esc are you using? Just trying to find a motor for you, MP
    The Xl-5 ESC

  20. #20
    RC poster
    Join Date
    May 2012
    Location
    New Hampshire
    Posts
    4
    So far I have burned up two of the T12 550 motors and yes, this is a needed upgrade to brushless.
    The motors, if cleaned routinely, will last a few months with stock gearing.

    Temperatures are the motors downfall. I believe temps under 150 degrees will allow the motor to function fine but anything over that will cook the motor and it is done. My first motor lasted several months and the last one only a month but I am sure that motor was extremely hot when it went.

    I haven't done the motor upgrade yet but will be soon.


    I have always thought it funny that an old RC10 I had 20 years ago still ran 20 years later while the new motors all have such issues. I never once cleaned that RC10 motor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •