Results 1 to 17 of 17
  1. #1
    RC poster
    Join Date
    Jul 2012
    Posts
    1

    Angry Firmware Upgrade Fails

    I just purchased a new TQi from the local hobby shop. Got home, replaced the receiver in my car, put the batteries in the transmitter and turned it on. All was good. I then downloaded the Traxxas Link App and as soon as the transmitter is connected, it tells me I have to upgrade the firmware to continue. I select the only available option, 'Proceed', which brings me to the version information screen. It finds the transmitter successfully with '2.0.44 to 2.1.56' next to it. The bottom button turns blue and says 'Touch Here to Proceed With The Firmware Update'. Selecting it brings me to a new screen with a single centered button saying 'Begin Update'. I select the button and the status label changes to 'Getting information from transmitter...' Almost immediately it changes to 'No response to the last packet. Retrying...'. After a moment, the screen changes to say 'Failed after too many retries. Please turn off and on the transmitter and vehicle and try again.' with a new button saying 'Retry Update'. If I select retry, same thing happens.

    I have tried power cycling both the transmitter and receiver. Uninstalling/Reinstalling the iPhone app. Rebooting the iPhone. Resetting the model memory of the transmitter to factory defaults and rebinding the transmitter and receiver. It will not install the update and it's extremely disappointing. Please advise.

    Thanks,
    Tim

  2. #2
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    17,073
    An issue like this is probably best handled by the Traxxas Customer Support team.
    In the US: 1-888-TRAXXAS (1-888-872-9927)
    Alt-248 on the number pad =

  3. #3
    RC poster
    Join Date
    Jul 2012
    Location
    Brasil
    Posts
    19
    The same problem here... Update .77

  4. #4
    Traxxas Employee
    Join Date
    Jul 2012
    Posts
    4
    Go to the app store and update to the newest version of the app. There is a fix in the new update to take that bug out.

  5. #5
    RC poster
    Join Date
    Jul 2012
    Location
    Brasil
    Posts
    19
    Quote Originally Posted by TrxRichard View Post
    Go to the app store and update to the newest version of the app. There is a fix in the new update to take that bug out.
    I've tryed that too yesterday and now again and had the same results..
    Will traxxas ignore that issue???

    http://imageshack.us/photo/my-images/849/fotosz.png/
    Last edited by csnakagi; 09-08-2012 at 04:21 PM.

  6. #6
    Traxxas Employee
    Join Date
    Jul 2012
    Posts
    4
    I would suggest calling Traxxas. 1-888-Traxxas

  7. #7
    RC poster
    Join Date
    Jul 2012
    Location
    Brasil
    Posts
    19
    Quote Originally Posted by TrxRichard View Post
    I would suggest calling Traxxas. 1-888-Traxxas
    That's possible if i had a fluent english... But i haven't...
    And i'm from Brasil...

  8. #8
    RC poster
    Join Date
    Jul 2012
    Location
    Brasil
    Posts
    19
    Ok... I've trainned my english with Traxxas suport yesterday... And they asked me to send my Tx to then...
    But i was thinking about it and i believe it pays to buy a new one...

  9. #9
    RC Racer
    Join Date
    Jun 2012
    Posts
    206
    well heck, if you dont want the old one send it to me... I will take it off your hands..
    1/10 Titan 775 bandit COMPLETED!!

  10. #10
    RC poster
    Join Date
    Jul 2012
    Location
    Brasil
    Posts
    19
    I boght a new one and it's ok now... And bought another one without dok base to take the radio and install the old dock...

  11. #11
    RC poster
    Join Date
    May 2014
    Posts
    10
    I had the same issue where I connected my iPod to the TX and did the firmware update. It killed the whole TX to where it wouldn't even power on. I called Traxxas, they were aware of the situation, gave me an RMA and I sent it back to them. They promptly sent me a new TX. This time, when I did the firmware update, I made sure the TX and RX were both turned on and sitting right next to each other. The firmware updated without any issues and continues to work fine to this day. My advice, make sure both TX and RX are powered on before you do the update.

  12. #12
    RC Racer
    Join Date
    Jan 2011
    Posts
    148
    I have a TQI 6528 (SN A0044324) from/for my summit and worked perfectly well with my lovely beast.

    I installed the BlueTooth Module 6511, it demands a firmware update. I connect the Module with my Android phone and start the process. The process goes through but never works. The Traxxas App shows a green TX connected icon. "TQi Transmitter (Bluetooth) 0.0.0 to 2.2.22)

    The transmitter is blinking orange. I lauch the firmware update.

    This is the information of the app:
    Attempting to perform firmware update...
    Getting information from the transmitter...
    Performing Update
    Skipping (stage 1 of 2 ) update
    Verifying (state 1 of 2)
    Updating (stage 2 of 2)...
    FAILED TO GET A RESPONSE FROM THE TQI TRANSMITTER...

    The Transmitter LED is now solid green.


    Whenever I turn on my Transmitter it flashes Orange and it won't connect to my Receiver/Summit.

    Application Version 5.2.0.5249 from April 27 2015 running on a Android Note 3 with Android Lollipop.

  13. #13
    RC Champion
    Join Date
    Jan 2013
    Location
    SE Texas
    Posts
    1,180
    My son did the update on his docking base TX(non bluetooth). Now It's just blinking both red/green (orange?) at the same time really fast and won't do anything.
    --
    "Dude,I almost had you"
    R.I.P Paul Walker

  14. #14
    RC poster
    Join Date
    Mar 2015
    Posts
    7
    Guys, have you tried rebinding the transmitter and receiver? It's a simple procedure:
    1- Turn both transmitter and receiver off
    2- Open the receiver box on your vehicle to have easy access to the link button
    3- While pressing SET button, switch on the transmitter - LED should be blinking red
    4- While pressing the link button on your vehicle's receiver, power on the vehicle
    If things go well, they should link in a second or two and LEDs on both ends turn green. Try it out.

  15. #15
    RC Champion
    Join Date
    Jan 2013
    Location
    SE Texas
    Posts
    1,180
    I've tried everything and mine won't stop the blinking.
    Can't rebind...can't get the iphone to connect...nothing.
    --
    "Dude,I almost had you"
    R.I.P Paul Walker

  16. #16
    RC Racer
    Join Date
    Jan 2011
    Posts
    148
    The orange blinking never stops. I can hold Menu or Set or both, it will blink orange forever.
    Unless I try to update the firmware, then it turns green but inoperable. Turning off and on, it will again blink orange.

    Traxxas Support told me to contact my local hobby shop in Europe. But I bought the TQi in the US. And the Firmware flash process destroyed the TQi, not "using" it. I am very frustrated.

    Crosspost here: https://traxxas.com/forums/showthrea...g-orange-light

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •