Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    May 2012
    Posts
    8

    Traxxas EZ Peak Plus Noisy Fan

    Greetings from Oz,(downunder)
    I bought 2 Emax's (3906) before the kids were born( 12 years ago).. the kids found them in the garage and started playing with them (the old batterys lasted 5mins) so i decied to buy another R/C( i have 3 kids) which was the traxxxas slash 4x4 ultimate with the Traxxas EZ Peak Plus charger..
    I have just recieved the package, plugged the NiMH battery which came with the car only to find a grinding sound comming from the fan in the charger.

    I'm a little disapointed.

    What are my options?
    ( if i send back its going to cost half of what i paid for the charger, and i wont be able to use the Slash)

    Regs John

  2. #2
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    308
    Mine does the same thing, has since day one, over 6 months ago when they first came out. Never a problem working though. I have to use it constantly to keep my lipos and my son's going. I'm looking to upgrade to one that can do them a little faster, just haven't decided what to do. I just ignore it and go on. Does it just make the noise for the first 20 seconds or so? That's what mine does and then sounds fine.
    FLM EMBE P4de "Digger" Slash MT Backsl4sh Summit

  3. #3
    RC poster
    Join Date
    May 2012
    Posts
    8
    Quote Originally Posted by EmaxxChris View Post
    Mine does the same thing, has since day one, over 6 months ago when they first came out. Never a problem working though. I have to use it constantly to keep my lipos and my son's going. I'm looking to upgrade to one that can do them a little faster, just haven't decided what to do. I just ignore it and go on. Does it just make the noise for the first 20 seconds or so? That's what mine does and then sounds fine.
    Yeap only for a short period and then its fine.. But still its quite annoying straight out of the box.


    Anyone else's have this problem?

    Regs John

  4. #4
    RC poster
    Join Date
    Nov 2012
    Posts
    1
    I just bought the EZ Peak Plus at my LHS. Was disappointed to find the fan bearing was 'chattering' from the beginning. Took it back & showed it to them. They exchanged it, no questions. Brought the 2nd one home and by its third use, is doing the same. Sad to see Traxxas product quality control this bad. Especially when the difference between a 'cheap' fan and a 'good' fan is maybe a few cents...on an item that the LHS sells for $100.

    While it may not be a problem now, eventually the tolerances get bigger, and the chattering will eventually not go away. This means the fan doesn't spin as fast as it should and it will not keep things 'cool enough' and lead to premature failure. Given the cost of the charger, defective out of the box on multiple units really has me questioning anything Traxxas.

  5. #5
    RC poster
    Join Date
    Jul 2014
    Posts
    1
    Yep, bought one new. Used it once without problem. Starting with the second use, the fan starts up noisy, and now it happens every use. After a few seconds, the grinding goes away. Annoying.

  6. #6
    RC Racer Rich2's Avatar
    Join Date
    Feb 2014
    Posts
    249
    Quote Originally Posted by anotherjohng View Post
    Yep, bought one new. Used it once without problem. Starting with the second use, the fan starts up noisy, and now it happens every use. After a few seconds, the grinding goes away. Annoying.
    Easy fix. open the case and give the fan bushing a drop of oil.
    No different than motors with bushings. I made mine more accessible
    by drilling a small hole in the case inline with the fan shaft, allows me
    to lube it now and then without opening the case.

  7. #7
    RC poster
    Join Date
    Apr 2015
    Posts
    15
    Quote Originally Posted by Rich2 View Post
    Easy fix. open the case and give the fan bushing a drop of oil.
    No different than motors with bushings. I made mine more accessible
    by drilling a small hole in the case inline with the fan shaft, allows me
    to lube it now and then without opening the case.
    Just curious as to how to managed to get the case open. I removed the 4 screws on the bottom of the unit, but it doesn't seem like it wants to open, not without prying anyways. I don't want to break it.

  8. #8
    RC Racer Rich2's Avatar
    Join Date
    Feb 2014
    Posts
    249
    Quote Originally Posted by JudgeDredd View Post
    Just curious as to how to managed to get the case open. I removed the 4 screws on the bottom of the unit, but it doesn't seem like it wants to open, not without prying anyways. I don't want to break it.
    You can pry it off, just make sure all the screws are out. Another
    thing I did while it was open was to drill a hole in the center of
    the case where it draws air through so I could oil the shaft without
    taking it apart again. Make sure to reinstall it so the the bushing faces
    out in order to oil it.

  9. #9
    RC poster
    Join Date
    Apr 2015
    Posts
    15
    Okay, thank you.

  10. #10
    RC poster
    Join Date
    Apr 2015
    Posts
    15
    Got it open last night and put 1 drop of bearing oil in the fan, it's running great now!

  11. #11
    RC Racer
    Join Date
    Jan 2015
    Location
    Nova Scotia, Canada
    Posts
    123
    I bought mine brand new and it's the same as everyone else's here. Pretty sad but that's the typical traxxas bearings for you. Just keep it lubed up and clear of dust and cigarette smoke and you will be fine. The fan will burn out eventually but is easily replaced.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •