Results 1 to 7 of 7

Thread: slayer problems

  1. #1
    RC poster
    Join Date
    May 2012
    Posts
    7

    slayer problems

    I am having problems tuning my slayer. I have a jato 3.3 and havent had any issues tuning it, but for some reason i can get the slayer right. No matter what i do it bogs down on take off then usually dies quickly there after. there is a ton of fuel spray coming out of the carb, i have leaned the hsn and adjusted the lsn and i cannot for the life of me figure out what to do. any help would be appreciated.

  2. #2
    RC Racer
    Join Date
    May 2011
    Posts
    147
    have you tried setting it back to factory specs and going from there? could need cleaned too.
    Last edited by FASTMAXX86; 05-20-2012 at 01:10 AM. Reason: added to

  3. #3
    RC poster
    Join Date
    May 2012
    Posts
    7
    First thing I did was go back to factory settings but it hasn't helped

  4. #4
    RC Enthusiast
    Join Date
    Aug 2011
    Location
    Boise Idaho
    Posts
    43
    there is a ton of fuel spray coming out of the carb,
    I missed this part the first time i read your post. check for a broken piston skirt or restricted exhaust. Not knowing the age or condition of the engine, its hard to tell.

  5. #5
    RC poster
    Join Date
    May 2012
    Posts
    7
    I should also add, that's once I resTart it there is a lot of smoke still coming out of the exhaust.

  6. #6
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    11,497
    Has the engine ever been apart? If so, the piston may be installed backwards.
    The Super Derecho

  7. #7
    RC poster
    Join Date
    May 2012
    Posts
    7
    I am gonna take it apart tonight I am converting it from a slayer to a pro.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •