Results 1 to 16 of 16
  1. #1
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424

    I think I killed a battery :(

    2200mAh Traxxas 25c 2s lipo

    Plug it in and, "LOW VOLTAGE!!!!!" I haven't used the battery in about a month, and the last time I did, the car wasn't driving right - turned out the battery was dead, so I unplugged it and said, "pfft I'll deal with this later" and a MONTH later, the ESC didn't even turn on, I thought the thing was dead, but then I remembered about the last time I used the car, I drained the battery.

    Idiot.

    I figure it's dead now?

  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    1,717
    Sounds dead!! Give your merv some love! give the summit a break!

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    what's the voltage?

  4. #4
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424
    I'll check later and post here.

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    if it's below 6 volts that will be trouble

  6. #6
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,849
    have you tried a different battery yet? if so then your lipo is done for maybe. check the voltage if its like 1-2v per cell then its done for more likely. my lipo fell below 3.0v #2 cell to 2.86 but didnt puff and balanced back up to storage fine. i discharged it to 6.0v 2s. charger is not good thats why it did it to mine but yours you left drained. time to buy another lipo
    DEU 8:18 ESV

  7. #7
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424
    Yeah the other lipo works fine, it just sucks that I've wasted ANOTHER $35.

    I'm pretty certain it's dead the charger refuses to charge it! Haha, Traxxas EZ-Peak Plus.

  8. #8
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424


    The battery is so dead it can't even power the LVA
    Last edited by krallopian; 05-12-2012 at 11:12 PM.

  9. #9
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Rotterdam Hoogvliet NL
    Posts
    886
    looks to me that its drained to much and died
    Xtreme has no limiits

  10. #10
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424
    Yeah that's what it is Mossie, "Discharged" is drained.

  11. #11
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    Hahahahah! I think your little low voltage device says it all
    What's a coffee if it aint Irish

  12. #12
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424
    Yeah that was pretty funny.

    I woke up this morning though and thought, "c'moooooooooooon, battery won't get the best of ME!" So I've fixed it:

    Total battery output was 3.2v (both cells totalled 3.2, TOTALLY dead) and so I put 100mA in to it with a current limited powersupply for about 30 minutes, and got it back up to here:


    Then threw it on the Traxxas Charger, and it had no issues with it this time:


    I'm charging it outside in a box, on the pavement JUST INCASE something goes awry.

    I have balance charged the battery at 1c every single time since I've bought it, AND ran at least 40-50 cycles through it, proof that taking good care of your batteries (... except for letting it drain to completely dead haha) will help you in the long run!

    Who's excited? THIS guy!

  13. #13
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    It would of been worse if you had a load on it and took it below 3 volts

  14. #14
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,424
    Exactly, letting it drain certainly wasn't as bad as draining it inside of something - although it didn't have the juice to even run the LVA haha.

    I put a load on it at 7v and it didn't drop a hair, so that's good news. Fully charged in 61 minutes, zero puffing and zero heat and fully balanced. PHEW!

  15. #15
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    989
    Ride on
    What's a coffee if it aint Irish

  16. #16
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,849
    you were lucky with that one. I would still keep an eye on it for the next couple runs atleast. nice you got it back up and running. enjoy. too bad you didnt get to order a new lipo JK
    DEU 8:18 ESV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •