Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Mar 2012
    Posts
    6

    corroded prop shafts

    any body have trouble with the bushings seizing in the housing? tried to replace my bushings on starboard shaft and the ends broked off and the rest will not budge. ordering new shafts/housing kits but was wondering if anyone else had this happen.

  2. #2
    Traxxas Marshal cooleocool's Avatar
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    37,431
    Can't say that I have, and I've had one of my Villains for 10 years now. Were you keeping the shafts and such properly lubricated?
    "Happiness depends upon ourselves." -Aristotle

  3. #3
    RC poster
    Join Date
    Mar 2012
    Posts
    6
    yes they were lubed after every run, and sometimes before, with 3-n-1 oil.

  4. #4
    Traxxas Marshal cooleocool's Avatar
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    37,431
    Do you run your boat in salt water?
    "Happiness depends upon ourselves." -Aristotle

  5. #5
    RC poster
    Join Date
    Mar 2012
    Posts
    6
    some times but it was always rinsed with fresh water and then oiled.

  6. #6
    Traxxas Marshal cooleocool's Avatar
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    37,431
    I would still say that it has something to do with the salt water. Like I said, I have never had this issue and one of my Villains is 10 years old. The other is even older, but that one is the one I bought a couple of years ago as a NIB kit (new old stock). But I've never driven them in salt water either.
    "Happiness depends upon ourselves." -Aristotle

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •