Results 1 to 4 of 4
  1. #1
    RC Turnbuckle Jr. danielhr77's Avatar
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    4,482

    Rear graphite brace 4826x problems

    Hey Guys,

    I just got a rear graphite brace 4826x and after installing it the brake lever no longer moves freely.



    There's a rounded plastic part that goes in the small rounded hole, and that guides the brake lever.

    It looks like that plastic part is putting preassure on the E-clip and creates this problem.

    Any ideas on how to solve this?

    Thanks!

    Daniel.

    He Who Dies With the Most Toys Wins.

  2. #2
    RC Qualifier
    Join Date
    Mar 2011
    Posts
    375
    I'm kinda surprised you found one of these. I have one on my tec and I think it's a little black plastic piece you are talking about? I probably put mine together wrong but I put it on from above. It slips out once in a while weakening the braking power but I just push it back in and it works fine. It sounds to me that you installed that plastic piece under the brace. I did just the opposite. So try that.
    If you can't beat it....destroy it!

  3. #3
    RC Turnbuckle Jr. Snook Man's Avatar
    Join Date
    Jan 2008
    Location
    Sugar Hill Ga.
    Posts
    8,387
    I removed a slight amount of the blue brake post on the bottom so it would sit deeper and allow just enough free play between the e-clip and the bushing. Just a little removal of material was all that was needed.
    No slipper/tall gearing/power = broken parts.

  4. #4
    RC Turnbuckle Jr. danielhr77's Avatar
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    4,482
    Thanks Snook Man! I was going to do that, but I wanted to check if someone tried it first. I'll do it and update this thread.
    He Who Dies With the Most Toys Wins.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •