Results 1 to 8 of 8

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC Qualifier
    Join Date
    Jun 2010

    Castle ESC issues

    I went to take my Spartan out for a run today and it has suddenly started having issues. I have no throttle whatsoever but the steering always works. When I plug batteries in there is no beeps or lights from the ESC at all. The receiver lights up fine and it rebinds without a drama.

    I've tried to recalibrate the throttle with no luck. I've switched between LiPo and NiMH batteries and modes. I know the ESC is getting power because I've checked it with my multimeter.

    Can anyone help me work out what is going on. I'm at my wits end and ready to punch something. Last time I ran the boat it was absolutely fine. I haven't changed a thing since it was last used.

    Further information...

    I just switched the steering and throttle channels on the receiver to see if the receiver was acting up and it started up like normal (albeit with the trigger for steering and the wheel for throttle). When I switched back it went back to borked again with no throttle but it had steering.

    Right, another update. I managed to get it to work in a way. I selected sports mode and it started up properly. The issue I then had was that when I gave it throttle and then released it to the neutral position the motor would still run for a few seconds. It eventually stopped though. I tried again and this time I went to brakes/reverse and you could hear it give out a huge thud when it stopped. I tried hitting reverse and this time when the trigger was released to neutral it wouldn't stop at all. I had to apply throttle forward for it to stop spinning (which also gave a massive thud as the rotor stopped). I unplugged the batteries and once again I'm back where I started... Steering but not throttle.

    Forth update. After typing the last message I plugged the batteries in again and it started up fine however it still had the issue of not releasing the throttle. I unplugged and then replugged the batteries and now it's back to no throttle.

    Geez, this is getting fun!!! It now seems like when I plug in the batteries and have steering but no throttle that it's cycling through modes. When I pull the trigger and hold it it beeps once, waits, beeps twice, waits, beeps three times and then repeats the process again.

    Could I have a transmitter issue?

    No transmitter issue, I just tried another one and it's doing the same thing. I also tried to reset the throttle position in the transmitter menu and it didn't help. I'm really starting to think the ESC is dead (which wouldn't surprise me given Traxxas' track record with dodgy electrics).

    Still no love and I've been fiddling with it for hours.

    If the ESC is faulty can I just drop in a Seaking 180 and run the stock motor? If so, is it much of an improvement?
    Last edited by cooleocool; 04-15-2012 at 09:50 AM. Reason: post merge
    Slash 4x4
    Rustler x 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts