Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Feb 2012
    Posts
    2

    Question RPM axle carrier problems...

    Does any one else have binding issues with the rpm carriers? I know i dont have the caps to tight on the pillow balls but its causing my steering to"stick" the servo cant center the wheels back up and it hums kinda loud unless i flick the steering wheel a little to center the wheels. Any suggestions? Do the carriers just need to wear in?

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,316
    When is the last time you tore down the servo saver and cleaned it?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Feb 2002
    Posts
    5,239
    also, there are 2 adjustments..... the pillow balls into the a arms, and the pillow balls to the knuckle... either can cause binding issues if not properly setup.....

  4. #4
    RC poster
    Join Date
    Feb 2012
    Posts
    2
    Just had it completely torn down to dye the chassis and install thetoyz aluminum front and rear diff housings, steerng arm post, toe links and rpm carriers. If i disconnect the steering linkage there is no binding so i know its not the servo or the saver. The pillow balls are not to tight into the a arms it still has full steering range. Adjusted with a caster camber gauge and toe in toe out gauge.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •