Results 1 to 4 of 4
  1. #1
    RC Enthusiast
    Join Date
    Feb 2012
    Posts
    24

    Not driving straight

    I know I am a NOOB, but I promise I gave it an honest effort and time trying to figure this out but I finally gave up.
    My Revo 3.3 is pulling to the right. No matter what I do trying to adjust the toe and even the steering links. Even the steering trim doesnt help me out to much. When I the servo, I hear a buzzing noise..
    So something is wrong and I am looking for a few veteren tips in solving this
    thanks in advance

  2. #2
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Simi Valley, CA
    Posts
    499
    What I recommend is that first you put the trim back to neutral. Then take the servo horns off the servos (if you are running two servos), put the wheels straight ahead then put them back on the servo in that position. Then adjust the links if necessary to make sure the servos are not working against each other. The steering links should be the same length. You should not hear any buzzing when they are at rest straight ahead.

    Once you have it close as I described above you should be able to get any remaining adjustment that you need by using the trim.

    Also you might want to check out page 37 of the manual for the description of the process above.

  3. #3
    RC Enthusiast
    Join Date
    Feb 2012
    Posts
    24
    That makes sense I will try that out. I didn't think about the servo horns

    if that works i will be be back to thank you

  4. #4
    RC Enthusiast
    Join Date
    Feb 2012
    Posts
    24
    Yes worked well
    Thanks for the pointing out the tip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •