Results 1 to 12 of 12
  1. #1
    RC poster
    Join Date
    Apr 2011
    Posts
    13

    vxl esc blinking red on my new slash 4x4

    I just got my slash 4x4 5 days ago and it worked for the first 2 days Of course I had to drive threw water because it said it is waterproof. Now when i plug in a fully charged nimh battery the esc blinks red about 2 or 3 times then waits a second then blinks red again. Sometimes the wheels will stear ut the throttle never works. I suppose it could be the battery I used the traxxas 7 cell not sure if it is waterproof. I ordered a maxamps waterproof lipo so i'll see if that will fix it but for now could someone please tell me what could be wrong with it.

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Did you check the receiver sometimes it gets wet and acts weird try to open it up to see if there is some water on it, is the led on the receiver steady or it is flashing, if the led is steady, unplugg the servo and give it a try if none of that works I guess it might the esc, then you should call traxxas and explain the issue your truck is still under the 30 days warranty so it won´t be a problem.

  3. #3
    RC Qualifier
    Join Date
    Aug 2010
    Location
    Mid South
    Posts
    389
    Make sure you are in NiMH battery mode. When I'm in the wrong battery mode (Lipo or NiMH and running the wrong battery type) the truck will do funny things.

  4. #4
    RC poster
    Join Date
    Apr 2011
    Posts
    13
    ok thanks I'll try that

  5. #5
    RC poster
    Join Date
    Apr 2011
    Posts
    13
    the servo now works so I think it's the esc it blinks once waits a second blinks twice waits again, then blinks 3 times

  6. #6
    RC Enthusiast
    Join Date
    Jan 2011
    Location
    Orange, CA
    Posts
    48
    Check ESC button of not stuck as it sounds like it could be the problem. Does the ESC blink immediately after you plug
    in the battery ? Or does it start blinking after you actually turn the ESC on ?

  7. #7
    RC poster
    Join Date
    Apr 2011
    Posts
    13
    when i plug in the battery it turns green then blinkd red once then twicew then 3 times.
    Also how do you ghange the battery mode.(nimh lipo) and how do you unstick the button.

  8. #8
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    you have a sticky button it is pretty usual, try to clean around the button and some wd40, if not open the esc case and push it, I would sand a little around the button to prevent from happening again.

  9. #9
    RC Champion
    Join Date
    Feb 2009
    Location
    Medway MA
    Posts
    2,104
    Ya it sound like you're going through the modes: training, race, and for/rev
    Nothin' like a 4 on the floor and a V8

  10. #10
    RC poster
    Join Date
    Apr 2011
    Posts
    13
    I unstick the key but now it is blinking green and still won't go!
    HELP ME PLEASE
    also how do you switch it to nimh mode and select training, race, and for/rev mode

  11. #11
    RC Racer
    Join Date
    Jan 2011
    Location
    Columbus OH
    Posts
    249
    how to switch from nimh to lipo is in the doc that came with it or look here: think its on page 14 or 24.

    http://traxxas.com/sites/default/fil...l_100112_0.pdf
    slash 4x4
    ToyotaTundra 4x4 '08 ((((((( (((((

  12. #12
    RC Qualifier
    Join Date
    Aug 2010
    Location
    Mid South
    Posts
    389
    Turn the truck off and continue to hold the button down until you hear the elevating chime sound. It seems like a pretty long time and your finger will start to hurt. After the sound release and it should turn a steady red for nimh or green for lipo battery running.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •