Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Jul 2013
    Posts
    1

    Can't get my tmaxx started

    I can't get my tmaxx started wont even turn over, the battery in the easy start is fully charged, has a new glow plug wire and a new glow plug, when I try to start it the motor light is only on then it shuts off after like 3 seconds them it shuts off and the glow plug light come on, any suggestions? I know it's not flooded and the piston moves so its not seized, the tmaxx is only a couple months old haven't used it too much so idk what it could b, thanks

  2. #2
    RC Competitor
    Join Date
    Jun 2013
    Posts
    98
    youtube ez start disassemble as this is main fault. It also could be the ez start motor is buggered. Worth a look but all parts are replaceable and done so with a cheap price.
    T-Maxx 3.3 #4909 Restored.

  3. #3
    RC Turnbuckle Jr. Wildman4910's Avatar
    Join Date
    Jun 2009
    Location
    Cocoa Florida
    Posts
    4,593
    That's the ez starts protection circuit kicking in, you have binding somewhere in the ez start, you need to pull it & find the problem.
    Look out for the tree/crunch!

    LiPo? Naw NITRO!!

  4. #4
    RC Racer
    Join Date
    Mar 2013
    Posts
    166
    Put a pull starter on it at east while you are trouble shooting the problem, this way you can eliminate a bunch of factors right from the start, mo pun inteaded.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •