Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2009
    Location
    The Netherlands, Zoetermeer
    Posts
    3

    E-Revo slower in 70/30 transmitter setting?

    Hi all,

    I'm new to this forum and this is my first post... I've put some time in finding a solution here, but cannot find any. Perhaps you have got any clue on why my E-Revo is slower when I put my transmitter in 70/30 instead of 50/50?

    I have the same problem with my Airtronics MX-3 FHSS transmitter. Somehow, the E-Revo is slower than the original 50/50 setting... Pulling my hairs out.

    Any yeah, I did to the reprogramming (a couple of times).

    Thanks!

    Regards,
    Bouke (which is a Dutch name )

  2. #2
    RC Qualifier
    Join Date
    Sep 2008
    Location
    Turks and Caicos Islands, BWI
    Posts
    623
    Are you doing this test with new batteries? If you are running 7 cells? Run 50/50 and 70/30 with fresh battries and let me know if its the same.
    Ray00
    E–Revo │ E-Revo BE
    ITCHY THROTTLE FINGER!

  3. #3
    RC poster
    Join Date
    Mar 2009
    Location
    The Netherlands, Zoetermeer
    Posts
    3
    Hi, thanks for the reply. Yes, it's a fresh set of 7 Cell 4500 mah NiMh batteries. Also tried with 2x2s lipos... No change...

  4. #4
    RC Racer
    Join Date
    Oct 2008
    Posts
    246
    connect a servo to the throttle channel and observe what it does.

    maybe construct something to mark the horn positions.
    E-Revo,700HO/Novak5.5,5Ah LiPos
    Baja 5B SS
    MERV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •