Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Aug 2016
    Posts
    5

    Slayer Pro 4x4 Nitro Engine grinding/Servo Squeaking

    I have the Slayer pro 4x4 Nitro. Its a quick little car that I drive almost every day. Recently the car has not been doing so well. First of all, the engine is making a weird grinding noise. Not sure why, but my spur gear and clutch bell are perfectly fine. Second of all, my throttle servo is making a weird squeaking noise. I took the servo apart and it does not seem to be stripped out. Have anyone had this problem before? And If so could you please tell me how to fix it.
    If I have to, I will purchase a different motor, or the same for my slayer

  2. #2
    RC Enthusiast
    Join Date
    Jun 2009
    Posts
    46
    Mine makes a squeaking noise as well. I am unsure of where exactly this is coming from other than the internals of the servo itself however it has made this noise for a long time so I just ignore it. Doesn't seem to be affecting it a whole lot. The only thing I could think of that could be grinding is something with the EZ Start (granted you are using this). Check the bearings and gears in the starting mechanism and see if there is anything abnormal. Mine gave out and there was a horrible grinding noise when I went to start it but obviously stopped after the engine turned over.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •