Search:

Type: Posts; User: jafo7489

Search: Search took 0.00 seconds.

  1. Thread: Gps module

    by jafo7489
    Replies
    11
    Views
    5,162

    I sent Traxxas an E-Mail last week and there...

    I sent Traxxas an E-Mail last week and there replay .At 09:18 PM 2/10/2013, you wrote:
    >They Traxxas are you ever going to sell what you advertise 6551 GPS
    >module and 6550 Telemetry Expander no...
  2. Sticky: My Rally in the works ...

    My Rally in the works
    ...
  3. Replies
    8
    Views
    1,423

    I missed it too but there is a rerun at 7AM I...

    I missed it too but there is a rerun at 7AM I have set up my PVR to get it and will up-load
  4. Replies
    4
    Views
    912

    2x3s in series 22.2VAC. I have some new prop's...

    2x3s in series 22.2VAC.
    I have some new prop's on order 2-3 size smaller.
    I did kill a flex cable on the 1st run it overheated the liner i had a spare and removed the liner on it and it was fine on...
  5. Replies
    4
    Views
    912

    Hydra Ice HV ESC 240A

    looking for some help I installed a Hydra Ice HV ESC 240A with a Big Block 1717 brushless motor (1650 Kv) out of my XO1 with Traxxas 8400 6s LiPo with a Prather S230 Stainless Prop and the ESC went...
  6. Replies
    85
    Views
    47,411

    Sticky: New Paint XO1

    New paint job

    http://i1293.photobucket.com/albums/b593/jafo7489/DSC01819.jpg
  7. Replies
    71
    Views
    20,342

    Sticky: Spartan letdown

    :mad:
    http://youtu.be/Bap7tcQcO1Y
  8. Replies
    2
    Views
    2,017

    XO-1 Horsepower ???

    Can someone tell me the apx HORSEPOWER that XO-1 has on 6LiPo and amperage draw of the ESC on the battres???
  9. Replies
    12
    Views
    1,863

    EVX-2 Not working HELP

    I just got this new Summit today worked fine for the 1st time (5 MIN) and then i went to use it the 2nd time and the ESC is blinking red and green and won't go all servo's working but no gas!!!!
    ...
Results 1 to 9 of 10