Search:

Type: Posts; User: 188slo50

Search: Search took 0.01 seconds.

  1. Binding tq transmitter to tqi reciever problems!

    Trying to bind my tq reciever to my 5 ch tqi reciever and can't get anything to work. I did the proceeds and it flashes red for and never stops any ideas to why or what I'm doing wrong?
  2. Replies
    19
    Views
    576

    Ok I think it was the connectors. I replaced it...

    Ok I think it was the connectors. I replaced it and ran a whole pack through it till I broke the rear axle carrier taking a jump but it didnt shut own until the low voltage took over. Thanks for the...
  3. Replies
    19
    Views
    576

    No local hobby stores that know anything. Ill...

    No local hobby stores that know anything. Ill call traxxas Mon and see what they say.
  4. Replies
    19
    Views
    576

    Let me play some more and see if I can narrow it...

    Let me play some more and see if I can narrow it down. I ordered different connectors for the battery to see if it helps. I know its not the battery's themselves unless both are bad. If I cant figure...
  5. Replies
    19
    Views
    576

    Just tore it down and it looks brand new on the...

    Just tore it down and it looks brand new on the inside. Any ideas?
  6. Replies
    19
    Views
    576

    My battery charger does! Being this is new...

    My battery charger does!



    Being this is new to me I have nothing to compare it to for the way it runs but Ill check the wires out and se what I can find out.
  7. Replies
    19
    Views
    576

    Its set at green solid light. I checked my packs...

    Its set at green solid light. I checked my packs and there 4.19-4.20 per cell.
  8. Replies
    19
    Views
    576

    VXL 3s doesnt run right ??

    Just got back into the electric stuff and bought this slash used with the VXL system. Im new to the lipo stuff so I had to buy battery's and charger and from what Ive read I seem to be doing all that...
Results 1 to 8 of 8