Search:

Type: Posts; User: Rampage27

Search: Search took 0.01 seconds.

  1. Replies
    13
    Views
    1,911

    Have you managed to get to the bottom of the...

    Have you managed to get to the bottom of the issue or is it still happening?
  2. Replies
    13
    Views
    1,911

    So i have checked my pinion and spur and all is...

    So i have checked my pinion and spur and all is ok. It looks like my motor is finished! When i accelerate there is no attempt from the motor to move the pinion etc. Instead there is just a high...
  3. Replies
    13
    Views
    1,911

    Have checked all the wires and all seems to be...

    Have checked all the wires and all seems to be fine. I am just shocked to already have a issue and yet i have barley had 20mins drive time with the car! Its sooo frustrating! Help will be greatly...
  4. Replies
    13
    Views
    1,911

    Its only when you accelerate! Store is open...

    Its only when you accelerate! Store is open tomorrow but thought it could be something to do with the esc? Im going to check that the servo lead is attached properly as a read that this could affect...
  5. Replies
    13
    Views
    1,911

    Please please please help as i cant find any...

    Please please please help as i cant find any solution online and i have tried everything possible!
  6. Replies
    13
    Views
    1,911

    Problem getting Rustler VXL to move

    Have had my Rustler VXL for 3 days now and it stopped working today! It has had only 3 runs and now it has just packed up?
    The reciever has a green light the esc has a solid red light and when i...
Results 1 to 6 of 6