Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jun 2014
    Posts
    2

    Two rotors are not spinning free. What do I need to do?

    I am sure this has been asked before but I could not find anything that matched my issue using search.

    I purchased my Alias at the Bristol NHRA event. My son and I have been loving this quadracopter.

    Today, we did a flip using the Aux 1 button and the Alias did the flip but did not recover itself like normal and it hit the asphalt. It was 30' or so in the air when we started the flip.

    The left side rotors (looking at the rear to the front) don't spin as free as the right side rotors. To be more specific the front left red rotor has virtually no free spin when I give it a flip of the finger and the black left rear while make one or two turns before stopping.

    The rotors on the other side just spin and spin. Obviously, it crashed on the front left rotor the most.

    I can fly it. I put one battery through it but I got to thinking about it and this cannot be good for it.

    What do I need to inspect, replace, what have you?

    All of your help is appreciated.

  2. #2
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,255
    Could be any one of three thins. Bent shaft, damaged bearing, or a bad motor. It is easy to take it apart and inspect the problem should be pretty easy to spot.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  3. #3
    RC poster
    Join Date
    Jun 2014
    Posts
    2
    I removed the motors. Rotors spin fine. Will order new motors. FYI the motors had four holes I them.

    Thanks and I'll post back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •