Results 1 to 3 of 3
  1. #1
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    515

    Issue with traxxas easy peak 6amp charger or nimh battery

    I've been having a issue with charging my traxxas 4200mah nimh battery. The battery came with my slash 4x4 LCG ultimate. Having been trying to charge it from its full discharge and the charger just keeps shutting off after 10 minutes or so saying full but I no its not. Checked the battery capacity in the program area and its at 5000mah so it should be ok. Right now I've bumped it up to 10,000 mah and seems to be charging longer now, its at around 2200 mah so I guess its ok. I'm keeping an eye on it to see if it shuts down again but ok so far. Do you think I solved the problem. Looks like I did, still charging so maybe I had to bump up the capacity, strange why it was doing this but I hope its fixed. If anyone can confirm this that the same thing happened to you and fixed it by bumping up the chargers capacity can yous please let me know. It was charging my 3000mah battery just fine but not the 4200mah nimh but seems ok now.

  2. #2
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    515
    Not sure what was happening but its charging good now. Could have been the battery was extremely low and took few try's to get it up to a voltage so it would start charging proper or that I bumped up the capacity from 5000 to 10,000mah or gust a freak thing and now its charging ok.

  3. #3
    RC Enthusiast
    Join Date
    Jun 2014
    Posts
    20
    when your setting up the settings right before putting the battery on the charger make sure you set the right settings and put it on maual instead of auto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •