Results 1 to 5 of 5
  1. #1
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    515

    ez peak plus storage. 2s lipo 4500mah

    Hi, I have a couple questions.
    1. While charging the 2s 4200mah lipo the charger balance charged it only up to a little over 2000mah or a little more like about 2200mah. Shouldn't it charge up to 4200mah or is this because of what storage was left in it, battery is new so I figured there was still volts in it for storage. Just seems odd that it only was charged that much. I now I had the charger set up for 2s lipo 7.4v and 4.2 amps on balance charge. Is this normal.
    2. Ran the lipo til noticed the truck slow down then put it on storage mode. It seems to be only set for automatically charging to storage at 0.1 amp which seems really low. So will it charge the battery to a storage setting for the battery. Seems I can only set the storage mode for battery type but can't set the storage level. Will it be ok or am I missing something. I've gone out to check the lipo and seems fine so for but at 0.1it looks like it's going to take a while.

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    1) Storage voltage = right around 50% capacity. So, charging from storage is only going to allow about 50% capacity to be put into the battery.

    2) Storage amperage on the EZPeak+ is maxed out at 2 amps and I believe 10 watts... those specs should be in the paperwork that came with your charger. What was/is the cell voltage?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    515
    Checked it out and seems to be ok. Cell voltage on charger was a little over 8 volts when the lipo was charging I believe. 7.4 volt lipo 2s battery though. I bumped up the amps on the storage charge to 1amp from 0.1 and watching until both cells reach 3.85. Is that ok. It seemed to run fine for about 40 minutes or so and not getting hot, battery that is. just wonder why it didn't charge up to 4200mah or id the mah divided between each cell a lipo has?. oops! I realized I put 4500 in the title, lol!, it's 4200mah
    Last edited by guy45ot; 04-13-2014 at 06:40 PM.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    4200 would be pack mAh.

    You probably won't see the full 4200mAh without discharging to a LiPo's absolute low of 3v/cell.... which should not be done in an RC EVER.

    LVC = 3.4-3.5v/cell = 6.8-7v for a 2S pack.
    Storage = approximately 3.85v/cell = approximately 7.7v for a 2S pack.
    Full = 4.2v/cell = 8.4v for a 2S pack.

    You will not see full mAh of any pack if only discharged to storage voltage.
    Whatever it is I just typed... could be wrong.

  5. #5
    RC Qualifier
    Join Date
    Mar 2014
    Location
    North Vancouver, BC
    Posts
    515
    Ok thanks, seems to be doing fine then on the info you provided, thanks. It almost at 3.85v. At 3.82v now. Taking a while but almost there

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •