Results 1 to 7 of 7
  1. #1
    RC Qualifier
    Join Date
    Sep 2013
    Location
    SoCal
    Posts
    520

    Need Some Help....Stumped???

    I just finished building a rustler roller I purchased. I'll post a build thread after I get this problem with the throttle fixed.

    My problem is that I installed a Traxxas #6518 5 channel receiver, with a Traxxas #6513 TQi Link 2 channel 2.4 GHz Transmitter, an HPI Flux Vapor Pro ESC (built by Castle), Flux Vektor 4000kv motor and Hitec 7975 Coreless servo. That's the electronics that I'm running. The problem arises when I turn on the esc and radio, and for whatever reason, the steering wheel on the Traxxas radio, actually is acting as both the throttle and steering for the rustler? If I turn the wheel clockwise, the tires go forward, and if I turn the wheel counter clockwise, the wheels reverse. The wheels also turn as the tires move.

    The actual trigger/throttle on the radio doesn't seem to do anything. I linked the Rx and Tx as per Traxxas recommendations, and I even tried another Traxxas 2.4 GHz Link #6518 receiver, and it still does the same thing. I unplugged the steering servo, and just left the esc plugged in the receiver, and the throttle still only operates with the radio's wheel, not the trigger, as it should. I have the connectors all plugged into the correct channels. Channel 1 for the servo, Channel 2 for the esc, and Channel 3 for the esc fan.

    Is this an issue with the Traxxas radio? I've never had a RC vehicle's throttle, be controlled by the steering wheel? Does anybody have any suggestions what the problem is? Please, any suggestions would definitely help.

    Thanks very much
    FLM RUSTY, FLM EMAXX, ERBE, SLASH PLATINUM 4X4

  2. #2
    RC Champion
    Join Date
    Jan 2007
    Location
    Michigan
    Posts
    1,677
    Weird, there's two channel 1 slots, are you absolutely sure your in 1 and 2 and not both channel 1's
    My previous sig conflicted with a forum policy.

  3. #3
    RC Qualifier
    Join Date
    Sep 2013
    Location
    SoCal
    Posts
    520
    Quote Originally Posted by dave00bear View Post
    Weird, there's two channel 1 slots, are you absolutely sure your in 1 and 2 and not both channel 1's
    I'll double check that again dave. Yes, this is definitely a situation that I've never experienced. Fingers crossed, I'll check the channels again. Thanks for the help brother.
    FLM RUSTY, FLM EMAXX, ERBE, SLASH PLATINUM 4X4

  4. #4
    RC Champion
    Join Date
    Jan 2007
    Location
    Michigan
    Posts
    1,677
    Make any headway on this problem?
    My previous sig conflicted with a forum policy.

  5. #5
    RC Qualifier
    Join Date
    Sep 2013
    Location
    SoCal
    Posts
    520
    Quote Originally Posted by dave00bear View Post
    Make any headway on this problem?
    You were spot on dave, you're the winner I completely overlooked the fact, that the 6518 is set up for nitros, with dual channel 1's available, for two servos....duh! I also didn't have my contacts in, so I'm surprised I even was able to find the receiver, let alone the microscopic channel designations denoted on the receiver. Albeit, it was pretty cool to throttle my car, and steer my front wheels, with a simple turn of the wheel on the radio LOL Thank you very much dave. Much appreciated brother.
    FLM RUSTY, FLM EMAXX, ERBE, SLASH PLATINUM 4X4

  6. #6
    RC Champion
    Join Date
    Jan 2007
    Location
    Michigan
    Posts
    1,677
    Cool man! Sometimes these things happen.
    My previous sig conflicted with a forum policy.

  7. #7
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    PM me if ya wanna bash at Greenwood Bashplex!
    Posts
    13,046
    If your into traxxas long enough, its hard NOT to do that lol
    Wanna bash at Greenwood Bashplex in Pittsburgh ???

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •