Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Mar 2014
    Location
    K-Bay, Hi
    Posts
    3

    Revo 3.3 won't go to higher speeds

    My Revo won't go any faster then first gear. I pull the trigger half way and it runs fine, I pull any further nothing happens but the engine revs up and the truck will move as if it's still in first gear. I took the trans apart and nothing wrong with it, I looked at the gear coming from the engine and that fine, and all the drive shafts are fine, so now I'm stumped. The only thing left is the engine I think but idk how to take that apart. So any advice would be grate thank you.









    USMC Lcpl Everetts

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    469
    Whats the history of the truck? U said tranny is good so that means slipper clutch is good right? How about the hsn? The hsn could be set too rich... how long u had the revo? So its not shifting into second? More more info. Help us help you.

  3. #3
    RC Turnbuckle Jr. icepick832's Avatar
    Join Date
    Apr 2007
    Location
    Indian Trail N.C.
    Posts
    3,294
    Why does everyone start with tearing stuff apart? Lol. If I had to guess based on limited info, I would say it's a tune issue. If it was the slipper clutch, it would also slip upon hard acceleration from a stop. Does that happen? As 2010 said, a little more info. But please ( and this is for anyone that reads this) stop ripping your trucks apart unless you know you need to. It will save you headaches on trouble shooting (unless you just like to take stuff apart hehe).

  4. #4
    RC Competitor
    Join Date
    Feb 2014
    Location
    Sweden
    Posts
    86
    Totally agree, don't take anything apart if you don't know what you're doing.
    There are people who have been educated to do this for you.
    They cost some money, but if you destroy your truck it will eventually cost you more
    Quote Originally Posted by icepick832 View Post
    Why does everyone start with tearing stuff apart? Lol. If I had to guess based on limited info, I would say it's a tune issue. If it was the slipper clutch, it would also slip upon hard acceleration from a stop. Does that happen? As 2010 said, a little more info. But please ( and this is for anyone that reads this) stop ripping your trucks apart unless you know you need to. It will save you headaches on trouble shooting (unless you just like to take stuff apart hehe).

  5. #5
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Copple Crown Mountain
    Posts
    386
    Use the KISS method. Keep It Simple Stupid. I agree with what was mentioned above by icepick...start with your tuning, small adjustments , test , repeat. Keep us posted!
    Last edited by Double G; 03-21-2014 at 07:03 AM.

  6. #6
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,675
    Start out by tightening the slipper. No matter how much the engine winds up, if the second gear clutch does not get enough rpm's it will not engage second gear.
    The Super Derecho

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •