Results 1 to 21 of 21

Hybrid View

  1. #1
    RC poster
    Join Date
    Aug 2013
    Posts
    6

    New castle sidewinder 3

    Hi ive been having trouble with my new sidewinder sv3 for my stampede and it wont work. I programmed it just like the manual said and i got power for about 10 seconds and then it stopped working

  2. #2
    RC Champion
    Join Date
    Jan 2005
    Location
    Nuclear Power Plant drainage ditch
    Posts
    2,714
    Are you sure it's set to the correct battery type? Lipo, NimH?
    All those who believe psychokinesis raise my hand

  3. #3
    RC poster
    Join Date
    Aug 2013
    Posts
    6
    Quote Originally Posted by Buzzforbrains View Post
    Are you sure it's set to the correct battery type? Lipo, NimH?
    Yes i am using the stock battery

  4. #4
    RC Qualifier
    Join Date
    Sep 2013
    Location
    SoCal
    Posts
    520
    Firstly, does your esc display the solid yellow light? If so, do you get the beeping noise when the esc is powered on? Just stay with me! Because the beeping sound is actually the motor, not the esc! There's no speaker in the esc, so the chiming noise you hear is actually the motor. The esc pulses the power to the motor, that's the chiming/beeping sound you hear. I would try a different motor, if the scenario I described is what you're experiencing. I had a problem where my esc would display the yellow light but the motor would sporadically chime, and it turned out that my motor connections were bad.

    If that's not your problem, what do you have the esc programmed at? Did you manually program it yourself, or, are you running the default esc settings. If you've manually re-programmed it, set it back to factory defaults and see if anything changes. Let me know!
    FLM RUSTY, FLM EMAXX, ERBE, SLASH PLATINUM 4X4

  5. #5
    RC poster
    Join Date
    Aug 2013
    Posts
    6
    Quote Originally Posted by quantumreality View Post
    Firstly, does your esc display the solid yellow light? If so, do you get the beeping noise when the esc is powered on? Just stay with me! Because the beeping sound is actually the motor, not the esc! There's no speaker in the esc, so the chiming noise you hear is actually the motor. The esc pulses the power to the motor, that's the chiming/beeping sound you hear. I would try a different motor, if the scenario I described is what you're experiencing. I had a problem where my esc would display the yellow light but the motor would sporadically chime, and it turned out that my motor connections were bad.

    If that's not your problem, what do you have the esc programmed at? Did you manually program it yourself, or, are you running the default esc settings. If you've manually re-programmed it, set it back to factory defaults and see if anything changes. Let me know!
    There is a chime when i turned it on and i just got power for another ten seconds then it died so i think it might be the battery

  6. #6
    RC Qualifier
    Join Date
    Apr 2013
    Location
    Portland, OR
    Posts
    294
    That might be the problem. If the ESC thinks you're using a LiPo when you are really using a NimH, the low voltage sensor will shut you down almost immediately.

  7. #7
    RC poster
    Join Date
    Aug 2013
    Posts
    6
    Quote Originally Posted by OSU Beaver 99 View Post
    That might be the problem. If the ESC thinks you're using a LiPo when you are really using a NimH, the low voltage sensor will shut you down almost immediately.
    Yeah i think that is the problem what kind of lipo do you reccomens

  8. #8
    RC Qualifier
    Join Date
    Sep 2013
    Location
    SoCal
    Posts
    520
    Quote Originally Posted by Matt505 View Post
    Yeah i think that is the problem what kind of lipo do you reccomens
    I recommend SPC liops all day. The quality of their packs is awesome, and their proces are definitely hard to beat, especially considering the performance of their lipos. Definitely the best bang for your buck. You can pick up a high quality 2S lipo, 5000 mAh 40C for only $31.95. Awesome deal. Plus SPC doesn't exaggerate their capacities. Very reliable and dependable.

    http://spcracingbatteries.com/index....tegory&path=59
    FLM RUSTY, FLM EMAXX, ERBE, SLASH PLATINUM 4X4

  9. #9
    RC Champion
    Join Date
    Jan 2005
    Location
    Nuclear Power Plant drainage ditch
    Posts
    2,714
    Also, I had no luck with the stock 7 cell batteries and this system. It just can't deliver enough amperage. It choked and lunged and would barely move. Look for a good Lipo with at least a 30C, 4000mah rating.
    All those who believe psychokinesis raise my hand

  10. #10
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    PM me if ya wanna bash at Greenwood Bashplex in Pittsburgh PA
    Posts
    13,149
    +1 for spc all day
    Wanna bash at Greenwood Bashplex in Pittsburgh ???

  11. #11
    RC Qualifier
    Join Date
    Nov 2012
    Posts
    740
    +2 for SPC

  12. #12
    RC poster
    Join Date
    Jan 2014
    Posts
    17
    castle will not run on nimh. need a strong lipo

  13. #13
    RC Enthusiast
    Join Date
    Jan 2014
    Posts
    37
    +3 spc batteries. I have you exact set up on my pede. I went with the 2s 50 c lipo


    Sent from my iPhone using Tapatalk

  14. #14
    RC Qualifier
    Join Date
    Apr 2013
    Location
    Portland, OR
    Posts
    294
    + 1 more for SPC. I have the same exact 5000 mah battery Quantum mentioned and the Castle SCT Sidewinder/3800kv setup in my S4sh and after racing with it yesterday I recharged the battery. The charger said it put 4,948 mah back into the battery, so like Quantum said, SPC's stated capacities are legit.

  15. #15
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    PM me if ya wanna bash at Greenwood Bashplex in Pittsburgh PA
    Posts
    13,149
    osu, just wondering what lvc setting your sidewinder is set at? I set mine up at 3.5v/cell and usually get 80-85% of the capacity. @ a 3.2v lvc setting I get around 100% capacity.
    Wanna bash at Greenwood Bashplex in Pittsburgh ???

  16. #16
    RC Qualifier
    Join Date
    Apr 2013
    Location
    Portland, OR
    Posts
    294
    Hey Rag6, this is the first Castle product I've had and I just got it last week. I have no idea how to program it yet so I'm running on whatever default settings were when it came from the factory. That said, it appears to be set to 3.4 vpc +/-. I've seen anywhere from 3.3-3.5 vpc just after LVC.

    The Sidewinder is on my Sl4sh build that I just finished, fyi, but it shouldn't affect the LVC.

  17. #17
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    PM me if ya wanna bash at Greenwood Bashplex in Pittsburgh PA
    Posts
    13,149
    Quote Originally Posted by OSU Beaver 99 View Post
    Hey Rag6, this is the first Castle product I've had and I just got it last week. I have no idea how to program it yet so I'm running on whatever default settings were when it came from the factory. That said, it appears to be set to 3.4 vpc +/-. I've seen anywhere from 3.3-3.5 vpc just after LVC.

    The Sidewinder is on my Sl4sh build that I just finished, fyi, but it shouldn't affect the LVC.
    Not sure of newer stuff, but every castle I have owned has come @ 3.2v out the box. It will be right in the manual on that setting. Actually the very first gen 1 sidewinder I had was set at 3.0v per cell...8(

    Hopefully the new ones are set at 3.4v. Its much easier on the batteries.
    Wanna bash at Greenwood Bashplex in Pittsburgh ???

  18. #18
    RC Racer
    Join Date
    Nov 2012
    Posts
    221
    I had an SCT and 3800 in my rustler and while performance would be better with a LiPO I ran my nimh's on that system with no problems until it ran through a puddle and blew out the ESC (I had the non waterproof model). However they come out of the box (atleast mine did ) in LiPO mode with LVC on and I had to disable it.

  19. #19
    RC Champion
    Join Date
    Jan 2005
    Location
    Nuclear Power Plant drainage ditch
    Posts
    2,714
    Quote Originally Posted by luckybobb View Post
    I had an SCT and 3800 in my rustler and while performance would be better with a LiPO I ran my nimh's on that system with no problems until it ran through a puddle and blew out the ESC (I had the non waterproof model). However they come out of the box (atleast mine did ) in LiPO mode with LVC on and I had to disable it.
    What kind of NiMh batteries did you use?
    All those who believe psychokinesis raise my hand

  20. #20
    RC Racer
    Join Date
    Nov 2012
    Posts
    221
    one venom 3000 mah and one duratrax 3000 mah. both 7 cell

  21. #21
    RC Champion
    Join Date
    Jan 2005
    Location
    Nuclear Power Plant drainage ditch
    Posts
    2,714
    Quote Originally Posted by luckybobb View Post
    one venom 3000 mah and one duratrax 3000 mah. both 7 cell
    Cool, I am glad to hear it runs on NimH.
    All those who believe psychokinesis raise my hand

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •