Results 1 to 8 of 8

Thread: 3.3 won't start

  1. #1
    RC poster
    Join Date
    Feb 2014
    Posts
    11

    3.3 won't start

    Just got the truck new to nitro. Tmaxx 3.3 new glow plug new glow plug lead wire new battery in ez start. Truck won't start what should I do?

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    469
    read the manual. if it spits fuel when trying to start u gotta lean the hsn a little till it starts.

  3. #3
    RC Champion
    Join Date
    Mar 2010
    Location
    Hackettstown,NJ
    Posts
    1,436
    Is this a brand new truck or is it a used one you purchased. The reason I ask this is because there are a couple of different ways to approach a truck that won't start. If new, follow the procedure for new engine break in.... If used, there could be settings which are way off. Once again refer to factory settings and go from there. What fuel are you using. I see from another post you were asking about changing out the ez start wire. was it because the truck wouldn't start or was the wire bad.. Need more info to try and help you.
    Maxx3.3/ rusty5700/ slash3800/ slash5700 /4tec3.3

  4. #4
    RC poster
    Join Date
    Feb 2014
    Posts
    11
    Quote Originally Posted by cenracer1 View Post
    Is this a brand new truck or is it a used one you purchased. The reason I ask this is because there are a couple of different ways to approach a truck that won't start. If new, follow the procedure for new engine break in.... If used, there could be settings which are way off. Once again refer to factory settings and go from there. What fuel are you using. I see from another post you were asking about changing out the ez start wire. was it because the truck wouldn't start or was the wire bad.. Need more info to try and help you.
    Thanks for responding okay truck is used got it off ebay I changed wire because old one was dirty and thought it would be wise to just replace it with an actual traxxas wire has traxxas top fuel 20% in it. I got it to almost turn over by putting my finger over the exhaust and building back pressure but now it isn't even trying to start ez start wand battery is charged and nothing happens took the glow plug out and the inside of the head looks wet flipped it over and tried to drain any fuel out of motor put glow plug back in still nothing happens I'm assuming I flooded it but I'm new to this nitro rc world and have no idea ez start lights both light up but nothing happens just sits like the wand battery is dead

  5. #5
    RC Enthusiast
    Join Date
    Nov 2011
    Location
    texas city, texas
    Posts
    38
    with the plug out..plug the wire to the glow plug..ground it against the side of the motor and spin it over...see if its glowing..if so reinstall it and go with factory settings..if not..plug is bad or no fire thru the wire..I have had the ez starter pac fail on that side of it causing no fire to the plug and the 4 prong connection not doing its job also will cause that...remedy the problms of ez start by installing a pull starter and using a glow starter...All of my trucks are pull just because of those reasons...lose the junk and save the weight.My $.02

  6. #6
    RC Racer
    Join Date
    Jan 2014
    Posts
    153
    Is the engine turning over at all? If not then u should check the terminals on the ez start motor and make sure there not loose and making contact. If its turning over and doesn't sound like it wants to start at all, then its probably flooding and you'd want to turn the needles back to factory like Cummins said. I know also that the ez start will sometime go into some protective mode where it won't let you turn over the motor and u have to wait a couple minutes. There's more about that in the manual.

  7. #7
    RC poster
    Join Date
    Feb 2014
    Posts
    11
    No it's not turning at all

  8. #8
    RC Qualifier
    Join Date
    Feb 2010
    Location
    Va
    Posts
    474
    If it wont spin at all I would pop the engine out and turn it by hand, then you can eliminate the possibility of it being locked up, unlikely from trying to start but it could be that the crank has a broken piece and got wedge making it not being able to spin. I would take the engine apart if it was me. if you can get it to spin check the pinch to see if its loose or tight. The guy probably sold you it knowing the motor was gone. Btw #DieselSquad
    Twin Brushless Latrax Teton, .21TM Jato

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •