Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Dec 2013
    Posts
    14

    Traxxas 9.6v 5000mah Problem

    So I'm guessing I got a Bad one like everyone else...

    Got it Brand New the other day, put it on my EZ Peak, it Beeps when it's done, I put it in my Rustler VXL, Turn it on, give the Truck some Throttle to make sure it's Working and it is, get the Body Clipped on, by the time I get outta my House and Outside, the Truck will barely Move.

    So do I have a Bad one like everyone else?

    I even Discharged it on the EZ, and Recharged it and same thing.

    Measured the Voltage with a DMM and IIRC, it was 9.14v

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Brand new pack?
    If so it could take a few cycles to liven it up... try researching "form charging" and following those instructions. If that doesn't work I'd call Traxxas to see if they will replace it. Or just start there if you want... lol
    Whatever it is I just typed... could be wrong.

  3. #3
    RC poster
    Join Date
    Dec 2013
    Posts
    14
    Ok, looked up Form Charging, and things are getting Confusing.

    This is what I came up with:

    5000mah 9.6v 8 Cell Battery
    Set EZ Peak Plus to Charge / Discharge 3 times
    Discharge at 2amps down to 7.2v
    Charge at 5amps
    EZ Peak Plus Clicks Off when it's done

    Does that sound Correct?
    Last edited by Duramaxxed; 12-19-2013 at 04:13 PM.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Sounds right from what I remember... haven't ran NiMH in forever. lol
    Whatever it is I just typed... could be wrong.

  5. #5
    RC poster
    Join Date
    Dec 2013
    Posts
    14
    Quote Originally Posted by Jimmie Neutron View Post
    Sounds right from what I remember... haven't ran NiMH in forever. lol
    Yea, I'm catching Crap from my Friends about it too.

    Just Ordered a few LIPO's before

  6. #6
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    It is a night and day difference between the two technologies, that is for sure.
    Whatever it is I just typed... could be wrong.

  7. #7
    RC poster
    Join Date
    Dec 2013
    Posts
    14
    Ok, just Finished the 3 Cycles, here's the Results:

    Charge 1 - 389mah
    Discharge 1 - 288mah

    Charge 2 - 768mah
    Discharge 2 - 552mah

    Charge 3 - 1315mah
    Discharge 3 - 996mah

    So, looks like things are getting better. I'm gonna keep Charging / Discharging and see where I end up after 3 again.

    How High should I get the mah before I try to see if it'll Hold a Full Charge?
    Last edited by Duramaxxed; 12-19-2013 at 07:20 PM.

  8. #8
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    See how it performs in the RC... it should keep improving with use and/or cycles though.
    Whatever it is I just typed... could be wrong.

  9. #9
    RC poster
    Join Date
    Dec 2013
    Posts
    14
    Yep, it's getting better.

    Unplugged it for the Night while I Sleep.

    I'll hit it Tomorrow with a Set of 5 Cycles and see how it goes.

    Charge 4 - 1925
    Discharge 4 - 1534

  10. #10
    RC Enthusiast
    Join Date
    Aug 2013
    Posts
    24
    I have found that LOTS of people have the same problem (like me) and I do not recommend this
    ziggy ziggy coco pop ziggy ziggy pop!

  11. #11
    RC Champion
    Join Date
    Jul 2007
    Posts
    1,256
    Where did you buy it? Usually when I have an NiMh that does that it's because it's been sitting for a very long time.
    I need R/Cers anonymous.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •