Page 2 of 2 FirstFirst 12
Results 41 to 47 of 47
  1. #41
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Baltimore,Maryland
    Posts
    370
    Small update.. Decided I didn't want to scratch up my Tbone bumper while I'm driving around. Remembered i had a roll of "Carbon Fiber" vinyl sitting around from prior projects not involving RC's. I think it came out pretty good, and now that I have the template on what size I need... I can easily cut it out and trim it up once its on. About 15 minutes and I'm done.. I also have some white "Carbon Fiber" vinyl. I may try to do the other Tbone bumper I have with that one to see what it looks like.

    Top View



    Front View





    What do you guys think? I'm still up in the air about it.. Not too sure how I feel.

    *Happy Thanksgiving*
    Last edited by Baltim0re28; 11-28-2013 at 05:16 PM.

  2. #42
    RC Champion
    Join Date
    Dec 2011
    Location
    Lake Jackson, TX
    Posts
    1,436
    that looks pretty good. Are you going to put the headlight and grille decals on? I'm thinking of getting that body for my bandit.
    Pro-2 SCB 2xSuperMaxx Revo-E SCT410

  3. #43
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Baltimore,Maryland
    Posts
    370
    I'm thinking of putting the decals on. I have an orange and black Raptor body that has the decals but for some reason I like the looks of the body without them though.

  4. #44
    RC Champion
    Join Date
    Mar 2011
    Posts
    2,487
    Yeah, badgless the carbon fiber looks hot, believe that lol. Cool you figured a way to keep it on the rc, off the lid, and have it look awesome. That stuff does a good job of protection too. Nice mod, Bmore!

  5. #45
    RC poster
    Join Date
    Nov 2013
    Posts
    9
    very nice looking truck!!

  6. #46
    RC Competitor
    Join Date
    Dec 2013
    Posts
    75
    Sweet rides man. I really enjoy that FLM chassis rustler! Any videos of that beast running?

  7. #47
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Baltimore,Maryland
    Posts
    370
    I had a video of it posted on a different thread trying to figure out why it was cogging so bad. Turns out it is most likely the batteries I was running. Only hit 59mph in the video though. I'll have to link it from YouTube onto here. As soon as I get some new batteries I'm gonna post a few videos in here. Time has just been consumed with alot of other things lately. I appreciate the compliments Rustler22, your truck looks pretty sweet man.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •