Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Jul 2013
    Location
    East Norway
    Posts
    13

    Problem with TQi firmware update on my transmitter

    Hi have anyone experience with updating firmware on the transmitter. I tried to update my transmitter but now it's not working. The transmitter just keep on flashing green/red fast when I turn it on, and on my iPod it only stay on verifying on the firmware update program. Have tried to reset the transmitter, but nothing happends.
    Anyone who can help me out? ....

  2. #2
    RC Qualifier
    Join Date
    Jul 2013
    Posts
    585
    Take a look in the electric forums for the TRX radios... It's one of your best bets IMO.
    PM for info.....

  3. #3
    RC poster
    Join Date
    Jul 2013
    Location
    East Norway
    Posts
    13
    Thanks for the advice, but could not figure it out. I have ordered a new tx, hope it arrives before we get ice on the lake and
    season is over

  4. #4
    RC Qualifier
    Join Date
    Jul 2013
    Posts
    585
    No problem, I would still try to tinker with your old TQi to see if you could get it to work. I updated the firmware for my Slash TQi and it took a while(30 minutes) which I thought it was odd but after building computers I learned patience or the computer learns to get dropped or go for a swim in the pool!

  5. #5
    RC poster
    Join Date
    Jul 2013
    Location
    East Norway
    Posts
    13
    Have tried to be patience for hours... Recived my new Tqi transmitter today, installed and no problem with upgrading the firmware on tx and rx... I will deliver my old tx, traxxas support told me it was a warranty issue...

  6. #6
    RC Racer
    Join Date
    Aug 2013
    Posts
    239
    I had a similar TQi with docking station problem after firmware upgrade. Replaced under warranty but cost me the shipping to Traxxas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •