Results 1 to 8 of 8

Thread: Overheating

  1. #1
    RC poster
    Join Date
    Oct 2013
    Posts
    9

    Overheating

    I bought a used spartan added 2 onyx 5000 11.1 lipo batteries and it ran fast for about 2 minutes then slowed way down when i brought it in the red light was flashing and the motor was super hot how do i fix this problem?

  2. #2
    RC Qualifier
    Join Date
    Apr 2013
    Posts
    367
    You need to run a seperate cooling line to the motor and esc. I had gotten a y plug and split the line coming from the rudder, then gave the motor and esc their own cooling lines, used another y harness and joined the hose back to the water outlet.

    That was just temporary until i installed my kintecracing 5 inch rudder with dual water inlets (so no y harness needed)Best upgrade Ive installed besides a new cooling jacket.

    Right now the water is coming in the esc, getting hot because the esc's heat. It leaves the esc hot and goes to the motor already hot so its not cooling it.

    Do you know if you have the version 1 or version 2 spartan? V2 has castle creations electronics.

  3. #3
    Traxxas Employee TireSlinger's Avatar
    Join Date
    Sep 2010
    Posts
    453
    Many things can cause heat issues. Everything from the prop being too deep in the water to incorrect stuffing tube alignment, rusted motor bearings, lack of lubrication of the flex cable, etc.

  4. #4
    RC Qualifier
    Join Date
    Mar 2013
    Posts
    369
    you def should do the 2nd cooling line to the motor.i did mine before it even hit the water.if anyone would ask me what do i really have to upgrade on my spatan it would be to add a seperate cooling line to the motor and a aluminum water jacket for the motor too

  5. #5
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Fredericksburg, VA
    Posts
    286
    I would check the driveshaft, motor bearings, Strut angle and the prop for nicks.
    Powered by Castle.....

  6. #6
    RC Enthusiast
    Join Date
    Jun 2013
    Location
    SW Ohio
    Posts
    26
    I agree that dual water pickup is a good idea but I don't think that would cause you to overheat in 2 minutes. I would do what the others say first. Check your drive line, motor and strut angle. Did you check anything before you ran it the first time? Was water coming out of the water outlet when it was running at speed?

  7. #7
    RC Champion
    Join Date
    Aug 2011
    Location
    El Cajon Ca
    Posts
    1,804
    No response from OP......
    "enjoy your ride"

    Dennis

  8. #8
    Traxxas Employee
    Join Date
    May 2013
    Posts
    32
    Check the jacket itself. It is possible that it is leaking, or that water is not going through the esc (ie debris stuck in the coils)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •