Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Sep 2013
    Posts
    11

    Not sure if EZ-peak PLUSE is working properly or 3s lipos issues

    I just got my EZ-peak a month ago and my lipos are about a month old also, I'm very confused I have a list of I don't knows I'm needing help with.
    1# When I do a bal charge on my 3s 11.1/5000mah traxxas brand lipos with the Dual Balance Charging Board Accessory I'm getting a low odd reading on cell 3 on both lipos way below cells 1-2 and also what I was told the range should be from traxxas{4.20v} here the charge readings.
    Lipo1~~4.16~4.20v~4.08v **24.92v
    Lipo2~~4.20~4.20v~4.09v **mah 00343
    I also did a single BAL charge and got the same readings THOSE last cells 4.08 & 4.09 don't seem in a bal range at all that far from 4.20 I was told by a tech @ traxxas to put them back on charge because they time out @120.[I GOT THE SAME READING after charger said full, I was charging the lipos separately } also I don't understand the mah and how it works I thought once charged the mah should read 5000 single charge and 1000 and also my amps dropped threw out the charge. Is this normal is my batt OR charger bad.

  2. #2
    RC Qualifier
    Join Date
    May 2013
    Location
    Ohio
    Posts
    427
    Did you ask them if its the charger or the lipos? If its your lipos then they should be under warranty.

    Traxxas stands by Power Cell LiPo batteries with the best warranty and exchange program available. For the first year of ownership, Traxxas will replace any battery found to be defective at no cost. After one year, any Power Cell LiPo battery in any condition can be exchanged for a new equivalent battery for just 50% of the new pack's retail price, no questions asked.
    Also never use lipos when the cells are out of balance. LVD will only detects the total voltage of the pack. So the cell with lowest voltage will discharge below the safety level and that's not good.
    Last edited by SouperkNight; 10-21-2013 at 07:17 PM.
    Did you say Traxxas?

    Yes with or without lipos.

  3. #3
    RC poster
    Join Date
    Sep 2013
    Posts
    11
    sorrrrrrrry

  4. #4
    RC poster
    Join Date
    Sep 2013
    Posts
    11
    They did not say. I really don't understand the charger being new to this that's why I was hoping someone would explain the question's I posted. Soupernight would you consider the cells way out of balance sir.
    Quote Originally Posted by SouperkNight View Post
    Did you ask them if its the charger or the lipos? If its your lipos then they should be under warranty.



    Also never use lipos when the cells are out of balance. LVD will only detects the total voltage of the pack. So the cell with lowest voltage will discharge below the safety level and that's not good.

  5. #5
    RC Qualifier
    Join Date
    May 2013
    Location
    Ohio
    Posts
    427
    Quote Originally Posted by SHOWBIZ View Post
    They did not say. I really don't understand the charger being new to this that's why I was hoping someone would explain the question's I posted. Soupernight would you consider the cells way out of balance sir.
    It depends how far out of balance they are and yes they are way out of balance. Are your settings set up right for charging lipos? I double check my settings every time before I start charging my 2s lipo.

    If you been having these issues for a month, are you seeing one or both of your lipos puffing?
    Last edited by SouperkNight; 10-24-2013 at 01:12 PM.
    Did you say Traxxas?

    Yes with or without lipos.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •