Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Oct 2013
    Posts
    3

    VXL-3M ESC light not on but unit is, no movement

    Hello, I just purchased the Summit VXL and have been running it hard for only two days. Car was running awesome, changed the battery and the green light on the ESC is not coming on, there is no movement with the drivetrain but the steering works. All the wires are in place, nothing looks cut or frayed or cracked or anything. The battery was just charged and I recharged another one and tried that just to be sure. No change. Also I can't turn the unit off, which I was able to do by holding down the EZ Set power button again for a second.

    Thanks for the help in advance! I want to get it running again I just got it, this thing is wicked fun!!!! Boo if I have to spend $50 bucks plus shipping and have to wait forever to get it back.

  2. #2
    RC Champion
    Join Date
    Jul 2012
    Location
    Yakima, Washington
    Posts
    1,421
    Well to start with Traxxas wants you to turn off your esc by unplugging the battery. Is the esc showing a red light or no light?
    With great brushless comes great responsibility.

  3. #3
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,282
    Try unplugging your servo... I have seen dozens of "working" servos cause all kinds of electrical havoc.
    Whatever it is I just said... I could be wrong.

  4. #4
    RC poster
    Join Date
    Oct 2013
    Posts
    3
    Thanks for the responses. I am new at this so I actually had to read up on the components to figure out what servo you were referring to.

    The ESC is showing no light. Unplugging the servo from channel 1 didn't do anything. I was doing that on the phone with support at Traxxas, who recommended sending in the ESC.

    I'm actually having two issues. Besides the ESC not having a light and no movement with the drivetrain, when turning left the wheels stick and click while trying to move back. Just happened to start occuring at the exact same time.

    After another conversation on the phone with Traxxas they suggested sending in the whole car (not the body or wheels) because it sounds like that servo gear is potentially busted as well. They'll most likely honor the broken parts because its so new and this way I'll no for sure if the $100 ESC is broken or not.

    First I think I'll see what the local shop thinks too. Can't hurt and I'm so new at this might as well before sending it away from Canada for like two months

  5. #5
    RC poster
    Join Date
    Oct 2013
    Posts
    3
    Thanks again for the responses. I confirmed the ESC was dead before sending it away to Traxxas. The issue with the steering servo was a few teeth busted off the crappy stock gears inside.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •